Skip to:
Content
Pages
Categories
Search
Top
Bottom

when setting ” register ” page as the homepage

  • Avatar of cupid4
    cupid4
    Participant

    @cupid4

    I set my “register” page as homepage in reading options, it’s a great addition in 1.5 to make things easier and it’s working so well, I just want to change the page that appear for logged-in users when they try to visit the “homepage” to activity, as it now show members page.
    to sum it up in a better way:

    new users>>see normal register page when visiting homepage.
    logged in user >> now they fall back to members page when visiting homepage, that is what I want to change for activity page.
    hope someone can help, I know it’s just one word to change but I can’t find where is this magic line :)

Viewing 19 replies - 1 through 19 (of 19 total)
  • Avatar of cupid4
    cupid4
    Participant

    @cupid4

    Since yesterday I tried to find that line at many files with no luck, anyone can help? :)

    Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    I’d probably turn this upside down though rather than doing under settings > reading I’d have a home.php in your theme that depending on if logged in user or not directs to a different template page. Should accomplish the same thing but gives you more granular control.

    I think I put the redirect in. Not sure if it is filtered. Will update later.

    Avatar of cupid4
    cupid4
    Participant

    @cupid4

    @karmatosed I thought perhaps the more native solution will be easier in updating and so, plus, I don’t know exactly how to accomplish your solution, you mean like creating a child theme and editing the index.php? BTW, do you know if there is a shortcode for buddypress register like the ones in bbpress?

    @djpaul I hoped the one who actually added the redirect see this topic, great you did :) will wait your update.

    It’s not easily filterable unless you want to duplicate a load of code, which I’d not recommend. Hmm. Make a enhancement request on trac asking for a filter, and I’m sure we can put it in for 1.5.1.

    karmatosed’s solution is also perfectly valid, so maybe go for that.

    Avatar of cupid4
    cupid4
    Participant

    @cupid4

    Thanks so much Paul, line found finally, and did the job so well, and I posted a ticket too:
    http://buddypress.trac.wordpress.org/ticket/3597

    I would love to use Karmatosed’s solution but as I wrote above, don’t know to accomplish that exactly.

    Avatar of cupid4
    cupid4
    Participant

    @cupid4

    Thought I should post this for anyone who come by the topic until 1.5.1:
    in the file:
    bp-members/bp-members-signup.php
    Find:
    bp_core_redirect( bp_get_root_domain() . ‘/’ . bp_get_members_root_slug() );
    Replace:
    bp_core_redirect( bp_get_root_domain() . ‘/’ . bp_get_activity_root_slug() );

    or replace activity with any slug you want logged on user to be redirected to.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    FYI, this filter has been added, and will be in 1.5.1. See http://buddypress.trac.wordpress.org/changeset/5237

    Avatar of cupid4
    cupid4
    Participant

    @cupid4

    @boonebgorges Thanks for this, I have another question, as a test, I installed 3.3 beta 1 today, and tried to install buddypress ( latest SVN version) but every time I click network activate it do nothing, the plugin is never showing as activated in the list of plugins or any further install instructions showing, is current svn not compatible yet with WordPress 3.3?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    The latest BP trunk is working fine for me on the latest WP trunk. Have you activated the plugin on a single blog first? If so, you might try deactivating it there first. If this is a test install, you might also try setting WP_DEBUG to true in your wp-config.php file, to see if any errors pop up during the activation process.

    Avatar of cupid4
    cupid4
    Participant

    @cupid4

    @boonebgorges sorry, but when to find the errors exactly when seeting WP-DEBUG to true? I can’t find any place for them in admin page or website front.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    If you have WP_DEBUG (underscore, not hyphen) set to true, there will be a line in your wp-config.php that says
    `define( ‘WP_DEBUG’, true );`

    Then, you will see warning messages at the top of the screen when something goes wrong.

    Avatar of Walid
    Walid
    Participant

    @walid3

    @boonebgorges I can confirm that buddypress 1.5.1 doesn’t work in WordPress 3.3 beta 1 with multisite install, I made a fresh install and that still doesn’t work or even activated, it doesn’t show any errors too. when you activate, it still show as unactivated in plugins list and no buddy-press install instructions appear.

    Avatar of Walid
    Walid
    Participant

    @walid3

    @boonebgorges just in case it make any difference, I’m testing on multisite with sub-domains, and trying to activate buddy-press normally on main blog.

    We don’t claim compatibility with WP 3.3 with BuddyPress 1.5.*. I expect it ought to work, however. BuddyPress 1.6, which we’re still building, will be verified to work with WP 3.3

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Hm. Network activation doesn’t work for me at all with WP 3.3 trunk, with any plugin (not just BP). That doesn’t seem good.

    I noticed that the other day, too, but I didn’t have time to check if it was just BP or not. Have you reported it?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

Viewing 19 replies - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.