Skip to:
Content
Pages
Categories
Search
Top
Bottom

When uploading an avatar image over 100k the site goes to white screen

  • Avatar of MickeyRoush
    MickeyRoush
    Participant

    @mickeyroush

    When uploading an avatar image over 100k the site goes to a white screen. No errors shown, just a white screen.

    I’m using WordPress 3.1.3
    BuddyPress 1.2.8
    Themekraft Custom Community 1.7.3

    It’s strange, if the file is under 100k (give or take) it will go to the next screen which will allow you to crop the image. And there’s no issue.
    But if it’s over 100k it will take a minute, then go to a white screen. When I check the wp-contents/uploads folder, the image is there even if it’s over 100k.
    So I know the files are getting uploaded.

    I’ve tried the following:
    Put the following in php.ini
    memory_limit = 128M ; Maximum amount of memory a script may consume
    ;*Allow PHP to accept large data
    post_max_size = 6M
    file_uploads = On
    upload_max_filesize = 6M

    Added the following line, near the top of my wp-config.php file:
    define(‘WP_MEMORY_LIMIT’, ’128M’);

    I’ve checked my bp-core-avatars.php file:
    if ( !defined( ‘BP_AVATAR_ORIGINAL_MAX_FILESIZE’ ) ) {
    if ( !$bp->site_options )
    define( ‘BP_AVATAR_ORIGINAL_MAX_FILESIZE’, 5120000 ); /* 5mb */
    else
    define( ‘BP_AVATAR_ORIGINAL_MAX_FILESIZE’, $bp->site_options * 1024 );

    I addd the following line to my wp-config.php file for the meantime, so it will give users a warning message instead of a white screen until I resolve this.
    define(‘BP_AVATAR_ORIGINAL_MAX_FILESIZE’, 102400); // 100k

    Not sure where else to look.

    Any help would be greatly appreciated.

You must be logged in to reply to this topic.