Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Why does my registration page only link to homepage?

  • Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    I am building a social network on my website and I created a page for sign ups or log ins and set it as my registration page and when I click view it takes me back to my websites homepage and not the page that I created for it. Can anyone help me figure this out?

    Thanks.

Viewing 18 replies - 1 through 18 (of 18 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @chase8705 when you go to the register page while you’re still logged in, default behavior is to go to home page. Log out first before going to registration page.

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    Ok I did that but then it took me to my Log In page but it says “User Registration Is Currently Not Allowed.” So I went into my general setting of wordpress and went to go check the “Anyone Can Register” box but it is greyed out. How can I make it so that anyone can register?

    Avatar of mattg123
    mattg123
    Participant

    @mattg123

    @chase8705 disable plugins, default theme and check if it’s still greyed out

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    @mattg123 If I do that, will it mess up anything that I already have on my site?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    WP/BP versions? What theme are you using? What plugins are installed?

    http://buddypress.org/support/topic/when-asking-for-support-2/

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    wp 3.5.1 / bp 1.7.2 Theme – WP Prosper. lots of plugins. lol @mercime

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    i mean wp version 3.4.1

    Avatar of mattg123
    mattg123
    Participant

    @mattg123

    @chase8705 disabling and enabling a plugin shouldn’t cause any problems, some save settings permanently however. Anyway, the fact you have “lots” of plugins, is probably the issue and the quickest solution is to disable them and check to see if the problems fixed.

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    @mattg123 ok. I will give it a try. Is it bad to have a lot of plugins?

    Avatar of mattg123
    mattg123
    Participant

    @mattg123

    @chase8705 btw, your theme’s not including wp_footer by the looks of things and many plugins use it, go edit your footer and wrap wp_footer(); in php tags

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    @mattg123 I’m kind new at this. Are you able to help me understand how to do that? I’m not trying to be a burden. If you can’t that’s ok. I appreciate your time.

    Avatar of mattg123
    mattg123
    Participant

    @mattg123

    having lots of plugins isn’t “bad” but the more you have, the more problems that can crop up, load times, compatibility etc etc etc

    to locate your themes footer, go to your dashboard>appearance>editor and locate footer.php you’ll probably find wp_footer(); on its own, it needs to be <?php wp_footer(); ?> @chase8705

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    Got it! I just did that. How does it look now? @mattg123

    Avatar of mattg123
    mattg123
    Participant

    @mattg123

    @chase8705 you’re using a caching plugin so I probably can’t see any changes, as long as you wrapped it in php tags everything’s good.

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    Oh ok. well I did that. I will try to deactivate and reactivate the plugins and see if it helps. @mattg123

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Did you make any changes in your template files? Something’s wrong with your theme. I see wp_footer(); near the bottom of the webpage. Open up your theme’s footer.php or the home page template and make sure that near the bottom of the file, instead of wp_footer();, it should be <?php wp_footer(); ?>

    Correct the code first, then check registration again.

    Avatar of Chase8705
    Chase8705
    Participant

    @chase8705

    That did it. I had S2Member plugin that was blocking it from allowing anyone to register. So I deactivated S2Member and WA LA! It now works. Thank you @mattg123 and to everybody who helped. I really do appreciate it.

Viewing 18 replies - 1 through 18 (of 18 total)

The topic ‘[Resolved] Why does my registration page only link to homepage?’ is closed to new replies.