Skip to:
Content
Pages
Categories
Search
Top
Bottom

Widgets not showing + unsupported operand types

  • Avatar of Megustaescribir
    megustaescribir
    Participant

    @megustaescribir

    Hi, I just upgraded to wmpu 2.7 and installed Buddypress. Everything seemed fine and dandy but when i try to put widgets on the homepage, even with the buddypress theme, these won´t show up, thought they are active on the dashboard.

    Additionally, when I click on “Blogs”, every blog entry in the blog directory features the following message:

    “Unsupported operand types in /home/freak/public_html/wp-content/mu-plugins/bp-core.php on line 930″. Could this have something to do with my homepage not showing the widgets?

    Thanks in advance,

    Chris

    You can see my website at: http://www.megustaescribir.com

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    if your site has not english language, you should download the latest svn version of BUDDY PRESS, and then set the widgets. RC-1 version has that problem

    Avatar of Megustaescribir
    megustaescribir
    Participant

    @megustaescribir

    Hi, thanks for your answer. I´ll try that. Funny thing is it worked yesterday when i activated the “sitewide activity” plugin. It disappeared afterwards…

    Avatar of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    they disappear when you change your language. if you use english all works

    Avatar of Megustaescribir
    megustaescribir
    Participant

    @megustaescribir

    I actually reverted to english on the wpmu admin´s option dashboard and it´s still not working. Maybe you´re talking about Buddypress´s language?

    Thanks a lot in advance,

    C.

    Avatar of Sgrunt
    Sgrunt
    Participant

    @sgrunt

    have you reverted MU on english and tried to re-add widgets one by one? however it was a known bug that was solved in the trunk version: download the latest and you’ll solve

    Avatar of Megustaescribir
    megustaescribir
    Participant

    @megustaescribir

    Hey, it´s working! Thanks a lot. I had to upload buddypress again. Funny because it´s the same version I previously uploaded… I´ll see what i can do now to have my site in spanish…

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Actually this isn’t a bug. It’s just the way widgets work in wp. The title is one way they are identified. Change the title (translated) and the widget doesn’t exist because it’s registered with the original language.

    Avatar of Megustaescribir
    megustaescribir
    Participant

    @megustaescribir

    Thanks to all. Everything (almost) is working now.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.