Skip to:
Content
Pages
Categories
Search
Top
Bottom

Wire comment form displaying to non group members, on groups page

  • I’ve noticed that on my groups page, for every group, even ones I’m not a member of, my site displays a comment form, so I can leave a comment on that group’s wire.

    If I’m not a member of that group, and I write a comment and hit ‘submit’, no wire comment is posted, but no error message is given… the page just refreshes. While this isn’t really harmful, it’s confusing.

    Why does the form display for non group members, when it doesn’t allow them to post? I’ve only noticed this on the group wires. & how can I restrict the form to only display to group members?

Viewing 5 replies - 1 through 5 (of 5 total)
  • This is just a bump. Even if there’s no quick fix for this, has anyone else has this issue?

    The form to post to a group’s wire displays, weather or not the user is allowed to post to that group’s wire. This doesn’t seem right, but I haven’t changed the code… what’s a designer to do?

    This might be a bug; but are you trying this with your Administrator user account?

    As a regular user on http://testbp.org/groups/it/wire/ (a group my regular user account isn’t a member of), I don’t have anyway of posting to the wire.

    Avatar of jesperpopma
    Jesper
    Participant

    @jesperpopma

    I’ve got the same problem.

    I just recieved a notification of a reply from a ‘non-group-member’. The reply is in the notification mail, but not on the wire.

    That’s really confusing for users !

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Wire doesn’t exist in BP 1.2, unless you’re using the backwards compatible plugin or a third-party wire plugin.

    Are you talking about the activity stream?

    Avatar of jesperpopma
    Jesper
    Participant

    @jesperpopma

    @r-a-y,

    I’m sorry I’m talking about the activity stream!

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.