Skip to:
Content
Pages
Categories
Search
Top
Bottom

Works fine for Admin, but Contributor has problems

  • I’m having no problems using the plugin as administrator, but a member of my BuddyPress network has continual difficulties with it rejecting emails and putting up an error message.

    These were all standard .com addresses (and the error message shows $email – is that correct – rather than showing the particular address). There were no typos.

    Both of us are using Macs with the latest version of Firefox, so…..

Viewing 13 replies - 1 through 13 (of 13 total)
  • Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    The “$email” text in the error message is a bug that’s been fixed in the next version.

    What version of BP are you running? And are you running WPMU or WP? What version? (It’s important because they handle email validation very differently.)

    BuddyPress 1.2.3/WPMU 2.9.2

    Thanks for such a prompt reply to this!

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    No problem :)

    How do you have email stuff configured at Dashboard > Site Admin > Options? Do you have banned domains? Are users able to Add User?

    No banned domains. But Add New Users is disabled (I’m assuming its the default) – so I’ll change that. The User concerned doesn’t have a blog….they were just inviting friends to join the BuddyPress end of things (they have subscriber status).

    So no doubt that all has something to do with the problem! I suspect I will have a lot of blogless users who’ll want to use the invite feature.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Let me know what happens – I haven’t done extensive testing with the Add New Users setting disabled, and I’ll be curious to hear if that’s what’s causing the problem.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I have always had ‘Add new user’ set to disabled (on all installs and three used to test this plugin) and have no issues so think the problem lies elsewhere.

    Members of my BP site are still messaging me about the Send Invites feature, saying it doesn’t work, or that it’s buggy. Most are cutting and pasting in email addresses, and it seems to spit them out as it sees fit, from the feedback I’m getting.

    I’ve found that if I past in “fred” and then manually type “@yahoo.com” or whatever, there are no problems, but clearly there’s an issue going forward for my site as it grows.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I’m at a bit of a loss as to why typing an address would be different from pasting it. Maybe it’s a whitespace issue – people are pasting in additional characters without knowing it? I’ll experiment with trimming the input. In the meantime, you could find the line in the plugin that does the email check and bypass it if you’re getting too many complaints.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    @gtn it would help to know exactly what your users are copying and pasting from, can you not ask one of them? also ask them to do a simple test, copy and paste an email, establish that this fails then ask them to type the same address in manually and see if that passes ok.

    It’s almost certainly a white space issue, if I add space after the address and try and send it does fail.

    Just need to trim the input value? wouldn’t a simple rtrim do the job? but that would see a space as valid?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    @hnla Thanks for testing the whitespace issue. trim() should do the trick. I will have a look later today.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Trim does the trick; just tested quickly on
    trim($_GET)

    But was lazy and dropped it onto the $returned_groups[]

    First address added white space to end, sending returns error message but second sending succeeds as the previously entered address has now been trimmed to perfection – well seems to work?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I experimented a bit and found the same thing as @hnla – extra whitespace does cause problems. I’ve trimmed user input where appropriate in version 0.6.2, out this afternoon. Thanks for your help!

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I’ll update later, hope @gtn picks up on the update.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.