Skip to:
Content
Pages
Categories
Search
Top
Bottom

/wp-admin no longer accessible after language install (spanish). Please Help

  • Avatar of Pro102
    pro102
    Participant

    @pro102

    Hi all: I’ve installed v1.0 of Buddypress, after properly configuring WPMU 2.7.1. It works in English. Now I’ve been to http://www.buddypress-es.com/noticias/descargas/ to get the buddypress translation in Spanish, I also installed the es_ES mo file under /languages. It all seemed to have worked until I went into the admin panel and switched from English to Spanish.

    Since I clicked on this, I can access our external site (http://nuestrorecetario.com/) as well as the login page but as soon as I try to login, the /wp-admin/ panel gives a broken page (completely fails to load). I tried to remove the es_ES language from the wp-config file, still cannot login.

    Any idea why WPMU/Buddypress choked and how I can get it installed?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Pro102
    pro102
    Participant

    @pro102

    I removed the es_ES mo file through FTP and now have access again. The admin panel now strangely displays in English for the most part except for some sections (groups = grupos). The external site also displays in Spanish: http://nuestrorecetario.com/groups/wine/ for example. This setup could work (if I knew how to make it work reliably).

    Question: are we supposed to NOT use the .mo files with Buddypress? Just the translations? It seems the mo file caused WPMU and Buddypress to fail. If so why did the Buddypress translation files alone not work when I installed them, then did start working after I activated the Spanish mo file (which I had to subsequently delete to regain access to the admin panel!)

    I feel I randomly got lucky here and have no idea how make this work reliably. Thanks in advance.

    Avatar of Pro102
    pro102
    Participant

    @pro102

    Last message for this evening: I added widgets to the front page, and the language switched back from Spanish to English :(. Looking forward to your comments… good night.

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    I also installed the es_ES mo file under /languages.

    You must install the bp language files to bp-languages.

    It seems you have uploaded bp language files to wpmu’s language folder…

    Avatar of Pro102
    pro102
    Participant

    @pro102

    Thanks Social. I did upload both language files, even the plugin translations under /wp-content/plugins/bpdev-languages/. (I had to create that folder)

    Every time I have the mo file installed the problem appears:

    * I select Spanish under Admin > Options = nothing happens (stays English)

    * Then select Spanish under settings = the admin panel crashes but does switch to Spanish. I then have to *delete* the mo file to get access back to WPMU.

    The site then switches to Spanish (90% translated, still some English left) until I make any change to widgets or anything else, then switches back to English by itself.

    Any idea?

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    um… maybe you should probably go to wpmu forum to get more feedback on this. Make sure you search the forum in case similar problem reported before.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.