Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] WP wouldn't auto upgrade, then this happened:

  • Avatar of Domina DeManda
    Domina DeManda
    Participant

    @domina-demanda

    At http://realshadesofgrey.com/wp-admin/

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/realgrey/public_html/wp-content/plugins/buddypress/bp-core/bp-core-functions.php on line 176 and defined in /home/realgrey/public_html/wp-includes/wp-db.php on line 992

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/realgrey/public_html/wp-content/plugins/buddypress/bp-core/bp-core-options.php on line 293 and defined in /home/realgrey/public_html/wp-includes/wp-db.php on line 992
    /home/realgrey/public_html/wp-includes/wp-db.php:992) in /home/realgrey/public_html/wp-Cannot modify header information – headers already sent by (output started atincludes/pluggable.php on line 875

    What my peeps see at http://realshadesofgrey.com/

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/realgrey/public_html/wp-content/plugins/buddypress/bp-core/bp-core-functions.php on line 176 and defined in /home/realgrey/public_html/wp-includes/wp-db.php on line 992

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/realgrey/public_html/wp-content/plugins/buddypress/bp-core/bp-core-options.php on line 293 and defined in /home/realgrey/public_html/wp-includes/wp-db.php on line 992

    I’m not sure what I did or how… but if someone could please help me fix it, I’d appreciate it! Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    I don’t know why you’re getting those warnings.
    I suspect it’s one of your plugins – one that has an admin page.

    For the public site, try opening the file: wp-config.php
    It will be in the root of your install.

    Look for this: define(‘WP_DEBUG’, true);

    And either delete it or change it to: define(‘WP_DEBUG’, false);

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    What version of BP are you on?

    Avatar of Domina DeManda
    Domina DeManda
    Participant

    @domina-demanda

    Thanks, shanebp. I found it and it was set to false… then I deleted it – still no diff :( Looks like I’ll reinstall both WP and BP at this point. Again, thanks!

    Avatar of Domina DeManda
    Domina DeManda
    Participant

    @domina-demanda

    Finally had to reinstall both WP and BP. Things are back up and working.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.