Skip to:
Content
Pages
Categories
Search
Top
Bottom

WPMU or Buddy Press is really slow

  • Avatar of Bbrian017
    bbrian017
    Participant

    @bbrian017

    I’m not sure what part of the system is slow but I get the worst loading times sometiems it’s ridiculous. The funny thing is I’m on a dedicated server so there’s no reason for the site to ever lag the way it does sometimes.

    It’s normally when visiting a blog or a blog article the loading time is about 7 – 12 seconds.

    Does anyone else experience this loading times frequently?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    If the server has been tweaked inefficiently or set up wrong, that could do it. Plugins can do it. There’s too many variables it could be without :

    a) looking myself :D

    b) knowing what’s on there.

    Avatar of Derek Bolden
    Derek Bolden
    Participant

    @derekbolden

    I looked at your site and three things right off the top;

    1). Ditch the Get Satisfaction button and link to them. That code for their widget is terrible AND it will definitely slow down your site. I think you should also think about the other social bookmark widget too. I would also add that there are time when the Facebook Fan widget loads really slowly. Better yet just take all of those off then see if your site loads faster. Bottom line keep the JavaScript widgets to a minimum.

    2). Add this to the top of your .htaccess file;

    AddType x-mapp-php5 .php

    AddHandler x-mapp-php5 .php

    3). If 2 worked add this to the top of your header.php

    ?php

    ini_set(‘zlib.output_compression’, ‘On’);

    ini_set(‘zlib.output_compression_level’, ’1′);

    ?

    (of course ad the <> )

    Try all three of those things and see how much faster you are loading… Andrea is right next time add a link to your site if you want help.

    Avatar of Bbrian017
    bbrian017
    Participant

    @bbrian017

    Seems to be way better after I bought more ram!

    The site and my other site ti was just too much!

    Now I’m running 2 gigs of ram!

    Avatar of Peterverkooijen
    peterverkooijen
    Participant

    @peterverkooijen

    What is this supposed to do?

    2). Add this to the top of your .htaccess file;

    AddType x-mapp-php5 .php

    AddHandler x-mapp-php5 .php

    I tried it. It just kills my site, white page. Does it depend on the server configuration?

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    Yeah, if you have php5. If not, I can see it borking.

    I have an inexpensive dedicated box at http://iweb.com/ with… I think 2 GB of RAM and a 3GHz Athlon CPU… and even without eAccelerator installed or zlib enabled at the moment… BP+WPMU screams. So… as they say… YMMV.

    Avatar of Andrea Rennick
    Andrea Rennick
    Participant

    @andrea_r

    I usually tell people for an active site, minimum 512 megs of ram.

    you don’t get that on shared. ;)

    Avatar of Bbrian017
    bbrian017
    Participant

    @bbrian017

    I have a 3.0 gig processor and 2 gigs of ram.

    Since I updated to the new buddy press I am running way faster!

    Avatar of mridul
    mridul
    Participant

    @thakursahib

    have you tried the minify plugin. it made my site 70% faster. when checked on firebug [page loading]

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.