Skip to:
Content
Pages
Categories
Search
Top
Bottom

Wrong image path – can’t show picture

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of Ralev
    Ralev
    Participant

    @ralev

    I temporary fixed the problem by using this solution:
    http://code.google.com/p/buddypress-media/wiki/fixingBrokenImageFileURLs

    It works for now. I’ll be waiting the update of the plugin :)

    Avatar of lovesaif
    lovesaif
    Participant

    @lovesaif

    wonderful!
    i had same problem … now fixed :)

    Avatar of kimi
    kimi
    Participant

    @whykimi

    can anyone guide about using this method?
    http://code.google.com/p/buddypress-media/wiki/fixingBrokenImageFileURLs

    i dont really know what to edit on

    # BEGIN rewrite rules for the BP Album+ plugin:

    Redirect 301 /blah/username/blah/public_html/ http://mydomain.com/

    # END

    so do we fill the blah and username beforehand?

    Avatar of Nick
    Nick
    Participant

    @tastytaste

    This is where I am stuck as well. I have no idea what is suppose to go in the “blah” I am also guessing that “http://mydomain.com” means I suppose to put my own url ? Just a clear example would do it.

    Avatar of Adil Javed
    Adil Javed
    Participant

    @adiljaved

    i am having same problem… :(

    Avatar of foxly
    foxly
    Participant

    @foxly

    @whykimi
    @tastytaste
    @adiljaved

    Here’s the clearest example I can think of:

    1) If your site uses CUSTOM SUBDOMAINS for each user (username1.yoursite.com, username2.yoursite.com, etc) AND you are having file path mapping problems, there is currently no work-around for 0.1.8 …although version 0.1.9 should work properly for you, once we get it released.

    Even with version 0.1.9, you should only use custom subdomains if you have a really, really good reason to. Subdomains require *2* DNS server look-ups, and give slower page load times as a result. Your users will find the site slower, AND you will also get penalized for slow page load times by Google and other search engines.

    ===================

    2) If your site DOES NOT USE CUSTOM SUBDOMAINS, here’s how to use the URL re-mapping function:

    a) You need to find the directory that WordPress is saving bp-media’s items to. It’s usually something like “/wp-content/uploads/album”. Note that the directory will not be created until you upload your first item.

    b) Paste “http://www.yourdomain.com” + “upload directory” into the “Base URL” box. Example: “http://www.yourdomain.com/wp-content/uploads/album” note that there is NO trailing slash.

    c) Set “Use image URL re-mapping” to “Yes”

    d) Click “Save”.

    Done.

    Note that this will not fix activity stream images. We will try for that in another maintenance release, otherwise it will come out in version 0.1.9.

    Thanks!

    ^F^

    Avatar of Adil Javed
    Adil Javed
    Participant

    @adiljaved

    thanks thanks alto @foxly i really solved the problem for me :) and its so simple…. :)
    activity stream images are still not working… but its okey :) i can wait fot ver. 0.1.9 :) great work buddy. :) keep it up!

    Avatar of Daniel
    Daniel
    Participant

    @altisona

    I have the same problem with the activity stream not working – great plugin otherwise – when is 0.1.9 due for beta release. I seem to recall seeing somewhere that you were aiming for 16 Dec 2010 – or is that wishful thinking…:)

    Avatar of foxly
    foxly
    Participant

    @foxly

    @altisona

    I’m going to try and fix the activity stream thing this week.

    0.1.9 is definitely not coming out on Dec 16 …lol… we were really busy with projects at our real jobs and weren’t able to put in enough time to get it finished this month. But we’re still working on it!

    ^F^

Viewing 9 replies - 1 through 9 (of 9 total)

The topic ‘Wrong image path – can’t show picture’ is closed to new replies.