Ready immediately is BuddyPress 1.2.5, which includes a number of important bug fixes to the 1.2 branch of code, and is another highly recommended upgrade. As always, be sure to back-up your installations before upgrading, and deactivate any dependent plugins that you might have to ensure there are no conflicts or errors during the process.

This version addresses a few WordPress 3.0 compatibility issues introduced in 1.2.4, and fixes a total of 49 reported issues.Check out the BuddyPress release history for details on the important fixes in this release.

We are Family

This time around we had a lot of community participation, which rocks because we’re starting to find lots of little obscure bugs that would have been overlooked otherwise. Props go out to abackstrom, boonebgorges, cnorris23, dwenaus, erich73, francescolaffi, hempsworth, jeffsayre, paulgibbs, paulhastings0, nuprn1, r-a-y, rvenable, wpmuguru, and everyone else that contributed. (If I missed you, leave a comment below and I’ll add you.)


Near the end of this versions’ development cycle, participation really ramped up mostly in part to better communication in the support forums from our core developers and moderation team. 1.2.5 would not have been possible without the passion and enthusiasm of our users, and we really appreciate your involvement in the project.

Plugin Authors

If you are a plugin author, you’re going to want to read this post about the new actions you should be using to load your code exactly where it belongs. BuddyPress 1.2.5 takes a big step forward towards being much more ‘dependent plugin’ friendly, but possibly at the risk of breaking existing plugins depending on how they’ve been developed.

Now go update!