Skip to:
Content
Pages
Categories
Search
Top
Bottom

buddypress not translating.

  • Profile photo of Zanzoon
    zanzoon
    Participant

    @zanzoon

    Hi,
    i have translated buddypress to arabic, named the mo and po files like that:
    buddypress-ar.po
    buddypress-ar.mo
    placed them in bp-languages
    but the problem is that it still shows english.
    in the admin the language is selected to arabic
    i’m using wpmu.
    thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Profile photo of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    You must also set your default language in WPMU’s wp-config.php file. Look for the following line in that file:


    define ('WPLANG', '');

    Profile photo of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    You’ll also need to make sure you have Arabic installed for WordPress, and if using multi-site, Arabic must be set as the site language in site wide settings.

    Profile photo of Zanzoon
    zanzoon
    Participant

    @zanzoon

    the language is set in site wide setting and this shows:
    define (‘WPLANG’, ‘ar’);.
    the blog is in arabic, but the problem that buddypress shows in english….
    thank you

    Profile photo of Zanzoon
    zanzoon
    Participant

    @zanzoon

    please help, thank you

    Profile photo of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Which versions of WPMU and BuddyPress are you running?

    Profile photo of Zanzoon
    zanzoon
    Participant

    @zanzoon

    latest buddy press
    2.9.2 wp
    thank you

    Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    @Zanzoon did you manage to get it to work for you?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘buddypress not translating.’ is closed to new replies.
Skip to toolbar