Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can’t Add Hyperlinked Text within ScholarPress Content

  • Profile photo of mariapeagler
    mariapeagler
    Member

    @mariapeagler

    I’ve tried this from both the Course Description and New Assignment, and the link feature doesn’t work. In fact, it doesn’t do anything: no error, no result at all when I click on the link button. I realize I can add websites and books in the bibliography, but I need these in the body text.

    Anyone else experienced this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Profile photo of mariapeagler
    mariapeagler
    Member

    @mariapeagler

    Also, just realized formatting for bulleted and numbered lists is off. After the first line, the text wraps to the beginning of the paragraph, not underneath the bulleted text. Basically, the indention in those lists is being ignored. Does not look professional at all. I may not be able to use ScholarPress if I can’t fix this.

    Profile photo of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    1. Confirming this. This was probably introduced with the new internal content linking feature, which is useless in Courseware and will have to be reverted back to original functionality. Issue added #40 https://github.com/scholarpress/buddypress-courseware/issues/40

    2. About Bibliography, there’s a button in the right menu, called `Bibliography` that will slide down the entries you added. Bibliography should not be messed with the content, it confuses students and are hard to find in long texts. Refer to them in the content, but do not try to put all in one basket.

    3. Formating of the lists, is a known issue in BuddyPress. I will make a patch for default theme, though remember, you can always add a `courseware.css` file with CSS rules to your theme that will be automatically included by Courseware.

    Thank you for the reports.

    Profile photo of mariapeagler
    mariapeagler
    Member

    @mariapeagler

    Thanks Stas. You are super fast responding to questions here on the forum. The weird thing about the list formatting is that it works outside of the courseware. I’m using the BuddyBase theme, not the default theme, and on a regular page or post it works fine. It’s only in the courseware that it doesn’t work; same with the links.

    Thanks again for the info. I’m not a developer but I’ll be working with one and this will be helpful in tweaking the theme.

    Profile photo of Stas Sușcov
    Stas Su?cov
    Participant

    @sushkov

    Thank you and keep in touch :)

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t Add Hyperlinked Text within ScholarPress Content’ is closed to new replies.