Skip to:

Error 404 – still there

  • AndreMartin


    As already detailed in this forum (post “Error 404 when creating project”, ) I had this particular error. There was no solution provided so I gave up trying out GTM.

    I now have updated to the latest version after all data (that I could find) was removed and the problem re-appears, identical to the previous forum post. Running latest WP and BP. Only qn I can come up with right now: does it require MySQL 5 or survives on 4?

    Anyone else got the same issue or questions and suggestions for me that I could report here to help with this issue?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I closed that topic because I couldn’t replicate the problem.
    Could you please create a video for me (using Jing or SnagIt tools on Windows and Desktop Recorder on Ubuntu) when this error appears? I would really appreciate this.

    I don’t know really which MySQL version is required – I’m sure only with PHP, WP, BP. On all my test sites there is MySQL 5.1.



    A note about MySQL: I can’t upgrade (stupid host) so I’m stuck on 4.1.25 for the moment, in case that gives issues to the project creation. PHP is >5.2.

    There isn’t anything to record on video, it’s explained with a few points and identical to the original post I did:

    First, to be sure we start from scratch, I did the following (let me know if I would have to manually clean up the database):
    1. I deleted all data (categories, tags..) in groups
    2. I disabled all groups in GTM admin
    3. I chose admin option to delete data *and* tables
    4. I disabled plugin
    5. I deleted plugin

    Assuming now we’re back to zero, I did the following:
    1. Install GTM (currently available 1.0.1)
    2. Activate the plugin (simple “activate” as no “network activate” mention)
    3. Checking GTM admin page: all fields & options correct, happy
    4. Click “Import” once and get a “successful” message
    5. All groups by default selected, I disable all but one for testing purpose
    6. Default “ToDo” shows up in that group name. I re-login as that group owner
    7.Successfully created a category (required to create a plugin)
    8.Create a private project, fill in all fields: fail!
    Error on red background:
    “There was an error creating new project, please try again.”
    Error above “Back to Projects List”:
    “Error – 404” “There is no project in the database with such ID. Please go to the main projects list.”
    Projects List page says:” There are no projects to display.”

    Just to be sure, I created a new (hidden) group and activated GTM support for it too (step 5). Then I repeated steps 6-8 with the same error messages as result.

    My question would be: “what exactly does it do when creating a project” so I can trace on that?

    I tested creation – everything is ok.
    How many tables you see in your database with prefix: wp_bp_gtm_? There should be 8 of them (tasks, projects, resps, discuss, taxon, terms, roles, roles_caps). I think that the problem in that 1 or more tables doesn’t exist in your DB.
    All saving processes are in file bp-gtm-core.php (from line 299). Projects are on line 436 (new) and 533 (edit).



    Here the tables I got:
    1) wp_bp_gtm_discuss
    2) wp_bp_gtm_resps
    3) wp_bp_gtm_roles
    4) wp_bp_gtm_roles_caps
    5) wp_bp_gtm_taxon
    6) wp_bp_gtm_terms

    Thus “tasks” and “projects” are missing which of course explains the whole problem in the web site.

    Running manually the table creation from bp-gtm.php for the missing tables, I get this error for both:
    #1170 – BLOB/TEXT column ‘resp_id’ used in key specification without a key length

    So, we’ve found the problem. I will try to understand why it’s wrong. Will update you soon here.

    I hope I fixed that. And yes – that’s MySQL error bacuse of its old version. Try to delete 2 strings in that file around lines 112 and 140: `KEY `resp_id` (resp_id),`
    for tasks and projects.



    Removing that line in “projects” and “tasks” table creation worked.
    Creating projects and tasks now is successful :)


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error 404 – still there’ is closed to new replies.
Skip to toolbar