Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error from Ipad, Iphone, & Android

  • Profile photo of Gayatriom
    Gayatriom
    Participant

    @gayatriom

    Cannot redeclare_ bp_dtheme_ajax_querystring…..
    Any thoughts?!
    I am using the latest versions of Buddypress and WordPress and Buddypress Mobile

Viewing 9 replies - 1 through 9 (of 9 total)
  • Profile photo of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Are you using template pack plugin on main site?

    Profile photo of Gayatriom
    Gayatriom
    Participant

    @gayatriom

    Hey yes.
    I am.
    Could that be the problems?

    Profile photo of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    yes, that is a problem. see if deleting ajax.php from buddypress-mobile/themes/default/_inc fixes problem.

    Profile photo of kelbycarr
    kelbycarr
    Member

    @kelbycarr

    I tried that and then ended up with this error:
    Warning: require_once(/home/typeamom/public_html/typeaparent.com/wp-content/plugins/buddypress-mobile/themes/default/_inc/ajax.php) [function.require-once]: failed to open stream: No such file or directory in/home/typeamom/public_html/typeaparent.com/wp-content/plugins/buddypress-mobile/themes/default/functions.php on line 10

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/typeamom/public_html/typeaparent.com/wp-content/plugins/buddypress-mobile/themes/default/_inc/ajax.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php:/home/typeamom/public_html/typeaparent.com/wp-content/plugins/buddystream’) in /home/typeamom/public_html/typeaparent.com/wp-content/plugins/buddypress-mobile/themes/default/functions.php on line 10

    Profile photo of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I hadn’t tested this plugin with template pack. When I get time I will. The problem is that ajax.php file is getting loaded twice.

    Profile photo of taubinator
    taubinator
    Member

    @taubinator

    I have the same issue … any updates. Thanks

    Profile photo of taubinator
    taubinator
    Member

    @taubinator

    fixed it …
    – open functions.php: located under plugins/buddypress-mobile/themes/default/functions.php

    – edit line 10 (replaced the location of the ajax.php to the location under the buddypress ajax.php file)
    require_once(‘/home/[account]/public_html/[folder]/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php’ );

    – replace [account] and [folder] with your specific location.

    Since it was being called twice, I just pointed it to the ajax.php in BuddyPress. Hope this helps.

    Profile photo of vinaykrypton
    vinaykrypton

    @vinaykrypton

    good information for further implementation. Thanks Vinay from Outsourcing Android Mobile Application Development

    Team, KryptonSoft, India

    the only solution that worked for me was to remove the line that user taubinator mentioned in his post above. The mobile template loaded immediately on my Android after that. Taubinator, thanks for leading me there!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error from Ipad, Iphone, & Android’ is closed to new replies.
Skip to toolbar