Skip to:

gpress options – Fatal error after upgrading to

  • rmac1962



    After upgrading to I receive a Fatal Error when trying to chose gpress options from Dashboard.

    Downgrading to

Viewing 17 replies - 26 through 42 (of 42 total)
  • just tried a fresh install of wp 3.0.1 with gpress version and got. no other plugins/etc installed

    [12-Aug-2010 10:59:43] PHP Fatal error: Call to a member function get_tppo() on a non-object in /Users/lp77/Sites/ on line 6

    i don’t need the rss feed atm so have commented out the function hook on line 33 and the site is up and running and maps are working.

    EDIT: saw this was posted elsewhere and the problem seems to be chrome & ff browser on mac. safari on mac loads the panel ok. sorry!

    the settings panel works ok on a clean install. the problem i just posted is from wp 3.0.1 install which has the following plugins installed and active:

    Breadcrumb NavXT – Version 3.5.1
    Contact Form 7 – Version 2.3.1
    Executable PHP widget – Version 2.1



    Am using CANVAS 2.5.2 from wootheme and I can’t install gpress and disable other plugins because the site would crash!



    This just broke my site with the message “Fatal error: Call to a member function get_tppo() on a non-object in /var/www/ on line 6”



    using the latest latest version

    So sorry guys – seems I now have 4 conditions to check for…

    1) WP Standard
    2) WP Standard and BuddyPress
    3) WP MS
    4) WP MS and BuddyPress

    I forgot to check the first one, please please confirm if those facing the error are just using standard WordPress, no multi-site or BuddyPress set-up…

    FYI – Am debugging now and hope to upload new version soon…

    I found the culprit! – It fixes at least 5 problems encountered by people who I simply could not explain – will not happen again – will now test with standard WordPress, WordPress MS and BuddyPress – am uploading version now, should be live soon…

    Vakantie Ameland


    Hi Mark,

    The problem with Foursquare boxes is solved now. I get the Foursquare Auth area and the “Remove presently Saved Auth tokens” So that part works!

    But I still do get the message: “There appears to be a problem with the Foursquare integration…” and the cause are these lines of code. This message should only be there if I did not enable credits four foursquare.. or am I wrong?

    But I enabled the credits!! And no map is showing and the error message is there??

    if($credits_for_foursquare == 'enabled') {
    echo 'This map was generated using gPress and Foursquare


    $content = ob_get_clean();
    return $content;

    echo '

    There appears to be a problem with the Foursquare integration...


    The “There appears to be a problem with the Foursquare integration…” message should only be displayed if the Foursquare has not yet been set-up properly or if there was a problem connecting to their API, and has nothing to do with the credits being enabled or not.

    I tried to log-in to your site to take a look but my password seems to have been re-set – either you will need to give me access again to go look or wait until I am somehow able to re-create the problem locally, but so far, I have been unable to recreate the problem – once again – everything works fine for me! :-s

    It seems the error might also occur if you have no friends on Foursquare, as the function first checks to see if there is an array, and an array would only be created if you have friends. Do you have Foursquare friends?



    Is it good to download the plugin now!

    @gpo1 – it should be – everything seems fine on my side – @christianebuddy reports a problem with Foursquare, but I cannot re-produce that problem, so as far as I can tell, everything is good – please let me know…



    It works fine

    @gpo1 – thanks for confirming!

    Since there were so many people facing problems, I think I’ll need a couple more people to confirm that their installs are all OK before I close this topic… :p

    upgrade to fixed for me. i’m running standalone wp install.

    That’s great news – I think that’s enough confirmations to close this topic – if anyone else has problems with future versions, please open a new topic – thanks again for everyone’s patience…

Viewing 17 replies - 26 through 42 (of 42 total)
  • The topic ‘gpress options – Fatal error after upgrading to’ is closed to new replies.
Skip to toolbar