Skip to:

Plugin incompatible with bp1.5

  • This plugin does not work at all with bp1.5. All of the options display all the time on the group page, and clicking on any of them as well as the follow button has no effect.

    I’ve spent the last couple of days trying to establish what was wrong with my child theme, but after eventually setting up a local install with bp-default theme active and no other plugins except this and BuddyPress 1.5.1, I get the exact same issue.

    We have some major sites relying on this functionality, and am currently at a loss on how to proceed, as we cannot simply remove the functionality.

    Am I missing something?

Viewing 5 replies - 1 through 5 (of 5 total)

  • ewebber


    @feedmymedia I have it working in 1.5 without any problems – it sounds like you might have a javascript issue somewhere which is causing the options to be visible rather than hidden

    Boone Gorges


    The plugin works fine on all my installations of BP 1.5.x. @ewebber is probably right that something is causing your JS not to load. Sometimes this happens because you are manually defining BP_VERSION and doing it incorrectly; try putting
    `define( ‘BP_VERSION’, ‘1.5.1’ );`
    into your wp-config.php.

    If that doesn’t work, you could try this

    Thanks for the replies. define( ‘BP_VERSION’, ‘1.5.1’ ); didn’t work, but i checked out the other thread, and following the advise within solved my problem.

    I moved:

    `if ( defined( ‘BP_VERSION’ ) && version_compare( BP_VERSION, ‘1.5-beta-1’, ‘<' ) ) {
    // Pre-1.5 versions of BuddyPress

    // Load the abstraction files, which define the necessary 1.5 functions
    require_once( dirname( __FILE__ ) . ‘/1.5-abstraction.php’ );

    // Load the group extension in the legacy fashion
    add_action( ‘init’, ‘ass_activate_extension’ );
    } else {
    // Load the group extension in the proper fashion
    bp_register_group_extension( ‘Group_Activity_Subscription’ );

    to the very bottom of the template bp-activity-subscription-main.php, and the js now loads fine.

    This seemed to resolve yannlossouarn’s (from the other thread) problem too. Any chance of a patch with this minor change in it? I’ve updated my copy of the plugin, but will lose the change when next there is an update.



    awesome, great fix thanks.



    I can confirm this “fix” worked for me to on bp 1.5.1

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin incompatible with bp1.5’ is closed to new replies.
Skip to toolbar