Skip to:

[Resolved] Poedit File Changes Not Taking

  • justbishop


    Anyone know the cause/solution to this? It’s driving me up a wall! Happens every single time I have to update BP, and I never remember how I get it resolved. I know the last time I just saved copies of the files with my changes made locally, but deleting what’s in the bp-languages directory by default and replacing that with my changed files doesn’t seem to do anything. I think I probably end up just making all of the changes over again, which is an annoyingly tedious task.

    on my child sites, I need “Blog Authors” in the admin bar to say “Shop Owners”. All of the files in buddypress/bp-languages reflect this change, but it’s just not taking:

    I have done everything short of redoing all of the changes (trying to avoid and figure out how to continue to do so in the future), including deleting my cache, uploading my local copies, and using my local copy of the .pot to regenerate a .po and .mo, and uploading those according to the Poedit instructions found here:

    Anyone know what the deal is?

Viewing 14 replies - 1 through 14 (of 14 total)

  • wedeem


    your language translations should reside in /wp-content/languages/my-custom-language

    Also in poedit are you saving the changes and exporting them to create the po and mo files?

    Have a look at



    So the buddypress.po,, and buddypress.pot files that I create shouldn’t be put into plugins/buddypress/bp-languages?

    And I’m following the steps under the “Translating With Poedit” heading on this WP codex page: Should I be doing it a different way for bp language files?



    2. Uploading the PO and MO files

    Now that you have generated your .MO file, move both the PO and MO files to /wp-content/languages/ on your server.



    Created the wp-content/languages/ directory and put the .po and .mo files into it. No change :(



    Are you sure ur file paths are correct?

    If ur custom language file is called buddypress-bishop.php, change en_us to bishop in the below

    `// change “en_US” to your locale
    define( ‘BPLANG’, ‘en_US’ );
    if ( file_exists( WP_LANG_DIR . ‘/buddypress-‘ . BPLANG . ‘.mo’ ) ) {
        load_textdomain( ‘buddypress’, WP_LANG_DIR . ‘/buddypress-‘ . BPLANG . ‘.mo’ );

    Sorry, am doing a pretty extensive redesign of the site in question and had to leave this be for a bit.

    Just had a few minutes and made the change above to my bp-custom, made sure the .mo file names in wp-content/languages match, and still no change.

    I guess I’m just going to have to redo the BP language files AGAIN, and continue to do so every time the plugin is updated. Grr.

    GAH! That doesn’t work, either! WTH?!

    Here’s what I have in my bp-custom:

    `define( ‘BPLANG’, ‘buddypress’ );
    if ( file_exists( BP_PLUGIN_DIR . ‘/bp-languages/riotcart-‘ . BPLANG . ‘.mo’ ) ) {
    load_textdomain( ‘buddypress’, BP_PLUGIN_DIR . ‘/bp-languages/riotcart-‘ . BPLANG . ‘.mo’ );

    I have downloaded a fresh copy of BP, then I took and edited the .pot file to suit my purposes, per the Poedit tut on the WP site (linked in a previous post). renamed the resulting files riotcart-buddypress.po and, then uploaded them to wp-content/plugins/buddypress/bp-languages.


    Boone Gorges


    You probably should not be keeping the mo file inside of BP. Do what @wedeem says and put it in WP_LANG_DIR, which is usually wp-content/languages.

    Also, you might be loading your textdomain too early. Try doing it in a function hooked to, say, bp_init.

    Thanks Boone :)

    I actually did try moving it to wp-content/languages, and that didn’t change anything, either.

    Not even sure what you’re talking about with the second part of your response, but thank you again!

    Just tried it again, for good measure. I have this in my bp-custom:

    `// change “en_US” to your locale
    define( ‘BPLANG’, ‘en_US’ );
    if ( file_exists( WP_LANG_DIR . ‘/riotcart-‘ . BPLANG . ‘.mo’ ) ) {
    load_textdomain( ‘buddypress’, WP_LANG_DIR . ‘/riotcart-‘ . BPLANG . ‘.mo’ );

    And have uploaded and riotcart-buddypress.po to wp-content/languages. No change.

    In addition to my last post, I have also added the language folder containing riotcart-buddypress.pot, riotcart-buddypress.po, and to wp-includes (as mentioned in the WP localization codex article), as well as added all 3 “riotcart-buddypress” files to both wp-content/languages and wp-content/plugins/buddypress/bp-languages.

    Still no changes.

    ETA: I just went drastic after I posted and flat out DELETED buddypress.pot, buddypress.po, and from wp-content/plugins/buddypress/bp-languages. Somehow, “Blog Authors” is still showing on the admin bar for child sites, even though I’m absolutely certain that I edited it to read “Shop Owners”! How can this even be possible?!!!?!!??

    Post edited. I did find the “All Blogs (n)” that was on my main site’s directory page hard coded into my template file. I honestly do not remember that ever being that way before, but whatev.

    There is still the mystery of why the admin bar on my network child sites still read “Blog Author” instead of “Shop Owner”, as I’ve edited all of the language files to read, though.



    justbishop – Over here:

    You say you have a snippet in bp-custom.php.

    Your snippet tells BuddyPress that your language file should be located and named as the following:

    But you have it named:

    Which is incorrect.

    Try renaming your language files in /wp-content/languages/ and see what happens.

    Oh dear gods. I love you, @r-a-y

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Poedit File Changes Not Taking’ is closed to new replies.
Skip to toolbar