Skip to:

V1.8 not allowing the selection of groups

Viewing 12 replies - 1 through 12 (of 12 total)
  • Sorry, meant v1.1.8

    Have rolled back to v1.1.7 and it is working.

    That sounds serious! I want to make sure I was clear on the issue you’re seeing. Is it:
    1) when you click on the [+], it doesn’t load the subgroups list but reloads the group listing page instead
    2) when you click a link to a subgroup, it doesn’t load the group page and reloads the group listing instead

    Also, are you using BP 1.2 or have you switched to BP 1.3?

    It is issue 2 when I click on the [+] it expands the list, but when I click on the link to the subgroup it returns to the group page. I’m running BP 1.2.9. When I go back to BP Group Hierarchy 1.1.7 it works fine in that when I click on the subgroup link, it opens the subgroup as expected.

    Tried 1.1.9 but still the same issue. V1.1.7 works fine.

    Just a little more background on this. The tree in both V1.1.7 and V1.1.9 both generate the same URL to the sub-group. For instance, in the case of the “University of Notre Dame” group which is part of the “Universities” parent group, the URL that is generated is The difference is that when V1.1.7 is loaded the subgroup opens but when V1.1.9 is loaded it returns to the Tree view (with the tree collapsed) at Even if I don’t rely on the link within the tree, and instead manually enter the link, it can’t find the group page and instead returns to

    It should be noted, that I’ve changed the order of the group menu using

    @pnerger, it looks like the end of your last post was cut off. What did you use to change the order of the group menu?

    I posted a new development version that can print some debugging messages with the `WP_DEBUG` flag and/or the WP Debug Logger plugin. If you can, please give that a try and send along the output (all lines from the plugin start with “BP Group Hierarchy”).

    Sorry David, not sure where “It should be noted, that I’ve changed the order of the group menu using” came from. I’ve not changed the order of the group menu but am using the option to hide the flat list.

    I’ll gather the debug information and will post it here.

    @ddean I tried to use WP Debug Logger but it gave me an error that there was no recognized plugin installed. I did this with the V1.1.9 that you had previously provided.

    Sorry, @pnerger. Only the development version has the debugging hooks in it.

    @ddean. I installed the dev version (it says that it is v1.2) and the problem with the sub-groups is not present. When I click on the sub-group it displays correct. So, I guess that I can continue to run with this one. Is that OK?

    @pnerger – If it says it’s 1.2.0 and not 1.2.0-testing, then you should keep using that. It is the release code, but I’m working on some better documentation before tagging a new release.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘V1.8 not allowing the selection of groups’ is closed to new replies.
Skip to toolbar