Skip to:
Content
Pages
Categories
Search
Top
Bottom

White Screen! Ugh…

  • Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    WordPress 2.8.4a and had BuddyPress 1.0.3 installed… We were having avatar issues with IE6 (crop tool wasn’t appearing)… I read that an upgrade would fix this as it uses JCrop in later versions… So I pressed the upgrade automatically to 1.2 and got the white screen… So I deleted the new buddypress files and directories and restored all my old buddypress files. Then only my header was appearing and I got an error message saying:

    PHP Fatal error: Call to undefined function bp_login_bar()

    So I figured my bp-core.php wasn’t being called, so I manually added this entry to my custom_functions.php file…

    require_once(‘/var/www/html/blog1/wp-content/plugins/buddypress/bp-core.php’);

    So all my pages work now except for my BuddyPress pages!!! Please Help!

    Thanks,

    Chew

Viewing 16 replies - 1 through 16 (of 16 total)
  • Profile photo of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    If you can get into the wp-admin, switch the theme to WP default. Then upload BP 1.2 manually with FTP client or similar.

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    I will try that.. Thanks DJPaul!

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    Now I am back to: PHP Fatal error: Call to undefined function bp_login_bar() :(

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    DJPaul? Any more ideas?

    Thanks,

    Chew

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    You need to upgrade to WPMU 2.9.1.1 to use BP 1.2.

    Also since you were using 1.0.3, I would have recommended upgrading to 1.1.3 first before upgrading to 1.2.

    One other thing, you might also need the BP Backwards Compatibility plugin:

    https://wordpress.org/extend/plugins/buddypress-backwards-compatibility/

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    Thanks Ray.. noted.. I would like to get back to 1.0.3 before I try anything else.. Can someone help… None of the members pages or the members search page work… I get a 404 error… Why would that be?

    Thanks,

    Chew

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    I had to manually do an include of the bp-core.php file and then…

    Perhaps another thing that may provide a clue.. I have the Remove BuddyPress Admin Bar plugin activated, but after coping the 1.03 directory back to the server, I have the Admin Bar still appearing.

    Thanks,

    Chew

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    Anyone? Sorry, dead in the water :(

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    Could there be a path in the database that got messed up that it’s not linking correctly to buddypress?

    Thanks,

    Chew

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Did you backup before upgrading?

    If so, revert your DB and filesystem to your backup.

    If you didn’t… :(

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    Nope… I just backed up the files, not the DB.

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    I have an earlier backup of the database… what tables do I need to import?

    Thanks,

    Matt

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    It’s basically anything with the wp_ or bp_ prefix.

    Also when upgrading, follow the instructions:

    https://codex.buddypress.org/getting-started/upgrading-from-10x/

    Profile photo of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Definitely upgrade from 1.0.3 to 1.1.3 then 1.2 otherwise you will mess up the database. BP doesn’t handle upgrades from multiple version numbers at the moment.

    Profile photo of chewdogg10
    chewdogg10
    Member

    @chewdogg10

    Wait… there aren’t just certain wp_ tables I have to restore? I have to restore all of them? Even wp_1_posts, etc?

    Thanks,

    Chew

    Profile photo of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    wp_ tables are WordPress/MU’s, and wp_bp_ are BuddyPress’.

Viewing 16 replies - 1 through 16 (of 16 total)
  • The topic ‘White Screen! Ugh…’ is closed to new replies.