Skip to:
Content
Pages
Categories
Search
Top
Bottom

500 error


  • stevenseagal
    Participant

    @stevenseagal

    If I click on orders, notifications, forums on the buddy press individual profile page I get a 500 error. How can I debug this or what is the problem?

Viewing 6 replies - 1 through 6 (of 6 total)

  • vapvarun
    Participant

    @vapvarun

    @stevenseagal follow the steps mentioned here and check error logs
    https://codex.wordpress.org/Debugging_in_WordPress
    based on error log we can suggest, how to fix it.


    stevenseagal
    Participant

    @stevenseagal

    Can I send the error log privately?


    stevenseagal
    Participant

    @stevenseagal

    [02-Jun-2018 18:09:52 UTC] PHP Notice: Trying to get property ‘ID’ of non-object in /www/energy_498/public/wp-content/themes/kleo/lib/plugin-pmpro/config.php on line 377
    [02-Jun-2018 18:09:52 UTC] PHP Fatal error: Uncaught Error: Call to undefined function bp_is_user_forums() in /www/energy_498/public/wp-content/themes/kleo/buddypress/members/single/home.php:102
    Stack trace:
    #0 /www/energy_498/public/wp-includes/template.php(690): require()
    #1 /www/energy_498/public/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php(155): load_template(‘/www/energy_498…’, false)
    #2 /www/energy_498/public/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php(61): bp_locate_template(Array, true, false)
    #3 /www/energy_498/public/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php(338): bp_get_template_part(‘members/single/…’, NULL)
    #4 /www/energy_498/public/wp-content/plugins/buddypress/bp-members/classes/class-bp-members-theme-compat.php(212): bp_buffer_template_part(‘members/single/…’, NULL, false)
    #5 /www/energy_498/public/wp-includes/class-wp-hook.php(286): BP_Members_Theme_Compat->single_dummy_content(”)
    #6 /www/energy_498/public/wp-includes/plugin.php(20 in /www/energy_498/public/wp-content/themes/kleo/buddypress/members/single/home.php on line 102


    Venutius
    Moderator

    @venutius

    It’s because you have overloaded the template file in themes/kleo.buddypress/members/single/home.php it’s trying to load an obsolete function `bp_is_user_forums() on line 102. If you did not create this file you need to speak to your theme support to fix it, otherwise the solution is to remove that function basically, it’s usually in an if function.


    stevenseagal
    Participant

    @stevenseagal

    @venutius is the function depricated? I commented it out and it works fine. Should I replace it with the current function?


    Venutius
    Moderator

    @venutius

    It’s no longer relevant, this was checking for legacy forums which are now no longer supported, so you can just remove it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.