Skip to:
Content
Pages
Categories
Search
Top
Bottom

404 error on bp links

  • Avatar of adiallo
    adiallo
    Participant

    @adiallo

    Hello,

    I am having trouble getting BP to run correctly, after installing the plugin all BP links return 404 error page not found. It seems like lot of people having this issues but with different configuration.

    I have wordpress 2.9.2 and the latest version of buddypress running in a subfolder called members : http://www.mysite.com/members/. without the bp the blog run fine.

    I read from different thread and tried few suggestions:

    – to change my permanent from default to links to date and name it didn’t work;

    – I deactive all other plugins in case of incompatibility with bp but didn’t help either.

    Any theme that I use return the same error, so I have a fresh install with bp default theme, my host is using FreeBSD (Unix) operating system and Apache servers but I am not allowed to upload my own .htaccess.

    I hope that i give enough information for you to be able to help me, I am totally desperate and clueless

    Thanks for helping

    adiallo

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of adiallo
    adiallo
    Participant

    @adiallo

    anyone please ?

    Avatar of adiallo
    adiallo
    Participant

    @adiallo

    I check my log file and here is the error I am getting

    “WordPress database error Table ‘members.wp_bp_user_blogs_blogmeta’ doesn’t exist for query SELECT * FROM wp_bp_user_blogs_blogmeta WHERE blog_id = 1 AND meta_key = ‘last_activity’ made by edit_post, wp_update_post, wp_insert_post, do_action, call_user_func_array, bp_blogs_record_post, bp_blogs_update_blogmeta “

    After that I reinstall the bp blugin but still I am getting the 404 error

    I don’t know anymore

    Avatar of adiallo
    adiallo
    Participant

    @adiallo

    Anyone please??

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    @adiallo – It won’t do you any good to bump your post every few hours. This board isn’t well trafficked enough that you should expect an immediate response.

    If you’re running standard (non-MU) WordPress, then you shouldn’t need the blog tracking feature. I’m not sure why BP is even trying to access wp_bp_user_blogs_blogmeta. When you go to Dashboard > BuddyPress > Component Setup, do you see a Blogs option? If so, disable it and see if it solves your problem.

    If you’re still stuck, try a total reinstallation of BuddyPress. Delete the plugin and reinstall. If you’re *still* having problems, try deleting the plugin, then dropping the tables in the database that start with wp_bp_, THEN reactivating.

    Or am I misunderstanding you and you’re actually running WPMU?

    Avatar of adiallo
    adiallo
    Participant

    @adiallo

    Thank you Boone, I am using standard WordPress installation WP 2.9.2.

    I just did a reinstallation of the plugin deactivate other plugins because I read somewhere it might not be compatible with BP.

    I change also the permanent link but I still cant access the page I get this error now “The page isn’t redirecting properly . the server is redirecting the request for this address in a way that will never complete” .

    Thanks again for helping

    Avatar of insanetisane
    insanetisane
    Participant

    @insanetisane

Viewing 6 replies - 1 through 6 (of 6 total)

The topic ‘404 error on bp links’ is closed to new replies.