Skip to:
Content
Pages
Categories
Search
Top
Bottom

404 error when clicking on edit profile

  • Avatar of boah123
    boah123
    Participant

    @boah123

    Hi,

    When I want to edit my profile I click on the ‘Edit Profile’ link. This link refers to:

    http://www.mydomain.com/members/admin/profile/

    However, after activating this link I receive an 404 error message:

    404 – File or directory not found.

    While loading the 404 page the page redirect to:

    http://www.mydomain.com/members/admin/profile/edit/group/1

    Thus, I can edit my profile but not in the way it should be.

    I’m using:

    WP: 2.9.2

    BP: 1.2.3

    IIS: 7

    WIN: 2008 webserver, with WP URL rewriting module

    PHP: 5.2.8

    SITE: domain, no subdomain

    Browser: error happens in IE, Firefox, and Chrome

    If you need more info, please let me know.

    How can I edit the page without first seeing the 404 error page?

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of mcrustk2
    mcrustk2
    Participant

    @mcrustk2

    Im having a very similar problem.

    I have installed WordPress MU & Buddypress on a sub domain:

    http://site.mydomain.com

    When I login I can click on ‘My Account’ if I click ‘Edit Profile’ I get a 404 error. Any of the other my account options such as change signature or change avatar works OK.

    Also noticed that if using the Album+ plugin, when I click upload a picture it does the upload but then immediatly shows a 404.

    Assume this is related in some guise to the subdomain. Maybe WordPress/Buddypress is best left on the root?

    Just installed:

    WordPress MU 292

    BuddyPress 123

    IIS6 (Hosted/Helm) PHP 5

    Avatar of boah123
    boah123
    Participant

    @boah123

    Thanks for your reply. Good to know that I’m not alone with this problem.

    I have installed my version in the root. This must be a problem on server side and php or permalinks.

    I hope someone will provide a solution!

    Avatar of Cce
    cce
    Participant

    @cce

    Avatar of mcrustk2
    mcrustk2
    Participant

    @mcrustk2

    Right,

    After some diggin, ‘Edit Profile’ works fine in Firefox but fails with 404 in IE8. Not tried any other browsers but this is an issue?

    Avatar of mcrustk2
    mcrustk2
    Participant

    @mcrustk2

    As mention on above post – worked for me.

    Thats one off my list!

    Thanks for Cce for Fix

    Cheers mate!

    Avatar of boah123
    boah123
    Participant

    @boah123

    Thank you, Cce. This help me solve the error.

    Avatar of paulinhapenedo
    paulinhapenedo
    Member

    @paulinhapenedo

    I’m having the same problem. “Edit Page” and “Create Group” are returning 404 pages.
    I’ve already tested @cce solution and it didn’t work, instead gave me a php error and my site wouldn’t even load.

    My config is:

    URL:http://www.viladigital.com.br
    WP 2.9.2
    BP 1.2.3
    Server: Locaweb (a brazilian host company) working with Windows 2003 – Enterprise
    PHP5
    Root instalation, no subdomain
    Wordpress + BuddyPress (with BBpress installed via BP)
    Custom BP Theme based on Default Theme
    I’ve changed my slugs inside of wp-config.php, but even when I delete this lines, the 404 pages keep occuring.

    Thanks a lot, guys!
    //

    Edit: nevermind, already saw what I did wrong. @cce solution is perfect!

    Didn’t change anything except for opening safari and that’s it. Thanks to @cce !

    yeah saved my ass!!! thank you so much @cce!

    Avatar of rtaguchi
    rtaguchi
    Member

    @rtaguchi

    As @paulinhapenedo said, i’m having the same problem, but only in IE or Google Chrome, when I use FF it’s ok…

    Does anyone know how can I fix it?

    Avatar of dude
    dude
    Member

    @pinhit

    sorry to but in here (totally un-related) but I can’t find my topics, can’t submit a fresh topic, or edit my profile on here, has their been a recent change to this site lately..?

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.