Skip to:
Content
Pages
Categories
Search
Top
Bottom

activity stream (1.2.5.2)

  • Avatar of Tatiana
    Tatiana
    Participant

    @svetka812

    when it happened to be a small image printed at the beginning of the post (like a thin banner or smiley little face) in it’s size less then 100px, (25px, for example), then on the activity stream page it gets enlarged to a 100px and looks really ugly. I suggest the “if size is bigger then 100 px” correction is made to an images handling code. I couldn’t find it.

    I have a community of poets and so most of their posts are poetry, as you could imagine.

    The written poem
    goes by lines
    of a certain length,
    and breaks often.

    Again, back to the activity stream, it presents posts (poems) in a horrible unreadable fashion – a paragraph of the one single line where everything is smashed together (exerts).
    I wish there was an option in settings to choose between a whole post or an exerts on the activity page, as it is given in the wordpress reading settings:

    “For each article in a feed, show
    o Full text
    o Summary”

    If anybody can tell me what and where to change in codes to fix it, I would really appreciate.

    http://svetkidoma.net/activity (it is all in Russian, sorry, but you will get a picture)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @svetka812

    Hi Tatiana – it would be better to ask this as 2 separate questions in the forums (one about images, and one about text). Also make the title a bit clearer, as that will get more people to help you (“activity stream 1.2.5.2″ is too general).

    To get more help and quicker: I suggest you create two question threads, something like: “how do I stop small images from blog post excerpts getting enlarged in the activity stream updates?” and “Why are my blog post updates missing paragraph breaks when shown in the activity stream?”

    My quick thoughts:

    images
    The problem with image sizes is because a core function in BuddyPress is forcing activity images, that don’t have their height or width set explicitly, to be 100px high. The function causing the problem is bp_activity_thumbnail_content_images().

    I’ll raise this as problem in the forums or maybe bug trac.

    update text
    I don’t have a problem with paragraph breaks in the activity stream. My blog posts are being shown correctly with the breaks. I’m using a default installation of BP1.2.5.2

    Paragraphs can be removed by a filter in WordPress / BuddyPress. Have you made any changes to your functions.php or bp-custom.php to turn off the ‘autop’ filter? i.e. do you have any code like this in those files:

    add_action(“init”,”remove_autop_filters_from_activity”);
    function remove_autop_filters_from_activity(){
    remove_filter( ‘bp_get_activity_content_body’, ‘wpautop’ );
    remove_filter( ‘bp_get_activity_content’, ‘wpautop’ );
    }

    Perhaps there is something in the blog template you are using that is doing this?

    Ask this one about paragraph breaks as a separate question in the forum (and include my comment).

    Cheers, Roger

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @svetka812 – these questions are also better asked in the forum “how to and troubleshooting” rather than “requests and feedback”

    Avatar of Tatiana
    Tatiana
    Participant

    @svetka812

    Roger, thank you a lot for your help! I will transform my post into 2 as you suggested.
    I am using a default BP them, and I didn’t change th codes. I will look for them.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.