Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatar Cropping always leads to “There was a problem cropping your avatar, please try uploading it a

  • I’ve tried literally everything, but can’t get avatar uploads to work. Everytime a user attempts to upload an avatar and crop, it leads to the “There was a problem cropping your avatar, please try uploading it again” message. I’m not using any other plugins, just buddypress (1.2.7), wordpress (3.0.4 multisite), and a custom child theme (fishbook). There doesn’t appear to be any javascript issues, and the permissions are all 755. I’ve seen countless threads about this go dead, but it is imperative I get this up and running. Help is much appreciated!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    Go to Settings -> Miscellaneous Settings
    Set “Store uploads in this folder” to “wp-content/uploads”.
    Set “Full URL path to files” to the REAL FULL PATH of your uploads.

    Then change bp-core-avatars.php line 389:

    Replace:
    `if ( !$path = get_option( ‘upload_path’ ) )
    $path = WP_CONTENT_DIR . ‘/uploads’;`

    With:
    `if ( !$path = get_option( ‘upload_path’ ) )
    $path = WP_CONTENT_DIR . ‘/uploads’;
    else $path = ABSPATH . $path;`

    I’m using Multisite, so this doesn’t actually exist. Also, that line number in bp-core-avatars.php is entirely different for me. I’ve seen this solution before for WP-Single but I have yet to see any solution for Multisite. Is there a way to adapt this solution to multisite?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.