Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatars…ongoing issue with this!

  • Avatar of bullitmagnet
    bullitmagnet
    Member

    @bullitmagnet

    For the last few months I have been using BuddyPress along with WordPress 2.9.2, now initially i noticed that there was some issues with the avatar thing but I overlooked it because I was concentrating on getting the site up and running and putting content on it. Now thow I want to address this problem and nowhere have I found a solution.

    When i upload an image through the avatar screen it then goes to the crop part, and shows nothing whatsoever, pressing crop just brings up an error about it not being able to crop the image, which is fairly obvious. When I use the image uploader to the media librbary it works wonderfully, but I nor any user can change thier avatars and are stuck with default gravatars, while these are quirky and everything I would prefer that my users could change them. I have read on some posts that it may be a GD issue, but that isnt the case as I know that I have the GDlib on the server as I have done other projects which have required it and they work without flaw.

    Can someone please provide me with some sort of solution?

    thanks…

    Bullitmagnet
    L33tlab.com

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of rossagrant
    rossagrant
    Participant

    @rossagrant

    Hi,
    Not sure if this will solve your problem but I had this problem and fixed it by defining the absolute URL for uploads in the miscellaneous settings in the dashboard.

    Go into the settings and where it asks for the full path to files, type in the full url to your uploads folder.

    eg. http://www.yoursitename/wp-content/uploads

    Let me know if it works!
    Ross :)

    Avatar of bullitmagnet
    bullitmagnet
    Member

    @bullitmagnet

    the only place in settings that allow for changing the file path is the misc, which I had set up when i first installed WP, it said optional but i figured it better to put it in just in case it was needed by something at a future date. So that dosent solve the problem, :(

    Its kinda annoying as I am opperating a gamer’s site and would like a more gaming related avatar, be it thier choice or not, on a side note though, is it possible to make a set of custom defaults with gravatars?

    Avatar of rossagrant
    rossagrant
    Participant

    @rossagrant

    hmm, sorry to hear that didn’t work. That seemed to solve it for me.

    I don’t have the knowledge to answer how to make a set of custom avatars but I have seen on many sites custom sets so yes you can definately do that!

    Avatar of bullitmagnet
    bullitmagnet
    Member

    @bullitmagnet

    ok, thanks for trying. Its just really bugging me now :) i assume theres something in the php files thats stopping it working, I am using a child theme ad I have read that people using WPMU can change something in wp-avatars.php and get it to work, but i dont have that file, or at least I havent been able to find it.

    Hopefully I can find some help somewhere

Viewing 4 replies - 1 through 4 (of 4 total)

The topic ‘Avatars…ongoing issue with this!’ is closed to new replies.