Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blank “pages” after install

  • Avatar of mbrutsch
    mbrutsch
    Participant

    @mbrutsch

    I did a clean install of WP 3.4.2, installed BP 1.6.1, ran the installation wizard, but it did not create any of the “pages” from the bp-page-settings page. I’ve tried adding the define(‘WP_MEMORY_LIMIT’, ’64M’) to wp-config.php, but that didn’t seem to help. Any thoughts?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    If the pages weren’t created (no reason they shouldn’t have been) create them manually as you would any WP page then head back to BP settings and tell it what pages you want it to associate.

    Avatar of mbrutsch
    mbrutsch
    Participant

    @mbrutsch

    Looking under ‘Pages’ in the dashboard, I see that it created pages named Activity, Forums, Members, etc. However, clicking on the ‘view’ link takes me to an undefined URL like ‘/wordpress/activate’. I can edit the page from there; it’s blank. If I add some text, like ‘test’, it saves it, but when I click ‘view’, it takes me to the same ‘not found’ url /wordpress/activate.

    If I look in the wp_posts table, I see the ‘activate’ page, with a guid of /wordpress/?page_id=9
    Loading that url redirects to /wordpress/activate, which does not exist.

    Avatar of mbrutsch
    mbrutsch
    Participant

    @mbrutsch

    If I create a new page ‘New Activity’ from Plugins -> Buddypress -> Settings -> Pages, it seems to create the page, but if I click ‘view’ from there, it goes to the non-existant /wordpress/new-activity

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    You don’t read those pages they are simply placeholders for BP, it uses their existence in forming it’s path to the required BP page. You do not do anything with these pages, do not edit or add anything – necessarily – to the page.

    All, technically, you need to is associate your pages and BP does the rest.

    You might need to visit the permalinks page to flush the permalinks cache – shouldn’t really need to but doesn’t hurt – and you have definitely set permalinks to anything other than the default as BP prompts you to? BP does not work with standard permalink structure must be one of the month or day structures or custom.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.