Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blog posts and comments not showing in global streams

  • Avatar of Oliver Wrede
    Oliver Wrede
    Participant

    @owrede

    I updated my installation to SVN BuddyPress (Rev 1324) and WordPress MU (rev 1728). Since that time blog posts and comments do not show up in the global streams (activity stream and global blog posts stream).

    I tried to set the site to WP_LANG to empty string instead of “de_DE” and also switched the language options to “English” – suspecting, that a language issue causes the problem – but it was not.

    I do NOT see this problem with the blog of the top-level bp site!

    Does anyone see this problem as well?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Nicola Greco
    nicolagreco
    Participant

    @nicolagreco

    report it in the trac :)

    http://trac.buddypress.org/newticket

    Avatar of Oliver Wrede
    Oliver Wrede
    Participant

    @owrede

    Ok. Crated ticket here: http://trac.buddypress.org/ticket/669

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Oliver, I’m running that exact setup and blog post from the home blog and other blogs show up just fine in sitewide activity. Are you saying that blogs other than the wpmu root blog are not showing activity?

    Do you have some kind of blog privacy plugin running?

    Avatar of Oliver Wrede
    Oliver Wrede
    Participant

    @owrede

    There is no privacy-related plugin in either /plugins/ or /mu-plugins/ anymore.

    What I have found out in the meantime is that after the movement of the buddypress plugin to the /plugin/ directory – I had to manually enable it on the top-level site. It also does appear as a regular plugin an ALL other sites (which feels flawed, as those sites should not list this plugin as “inherited option”).

    The other sites get the standard MU-Admin bar. If I enable the BuddyPress plugin on that sites manually, I do get the BP-Admin-Bar again and it seems that their updates are being shown on the top-level site again. This feels like I need to got through all of the MU blogs an enable the BuddyPress Plugin manually.

    From my conceptual understanding I think this can’t be the intended way – a BP installation should be globally – not per blog.

    Avatar of Oliver Wrede
    Oliver Wrede
    Participant

    @owrede

    Update:

    I was wondering about BP behaving like a ordinary plugin – so I re-read the forum post regarding the movement from /mu-plugins/ to the /plugins/ directory (see http://buddypress.org/forums/topic.php?id=1994)

    I stumbled over the part “enable each plugin but CORE first” there. In my context the BP plugins shows up as a single ordinary plugin. I can’t “enable CORE first” I wonder if that is realted to the issue I see here…

    Avatar of Oliver Wrede
    Oliver Wrede
    Participant

    @owrede

    Update:

    I seem to have an issue related to the WPMU-Version.

    On the page http://buddypress.org/forums/topic.php?id=1994 I overlooked the “Please also make sure you are not using the MU trunk, but the 2.7 branch.” note — I was using the WPMU trunk. So I “downgraded” to the 2.7 branch.

    Now I have “Activate XYZ plugin sitewide”-Options in the Plugin area. I still have a single BP-Plugin though. I activated the BP Plugin sitewide. And it seems to worl fine.

    But I ran into following problem:

    I needed to update “/wp-includes/capabilities.php” to the one of the trunk-Version. The one of the 2.7-branch gave me this error on all pages:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in
    /www/wpmu/wp-includes/capabilities.php on line 537

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in
    /www/wpmu/wp-includes/capabilities.php on line 537

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in
    /www/wpmu/wp-includes/capabilities.php on line 539

    Discussion is not continuing on http://buddypress.org/forums/topic.php?id=1994

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.