Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress 1.2.4.1 and WPML Multilingual CMS problem

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Hans
    Hans
    Participant

    @hanss

    For me too. **** it. After I upgraded to BP 1.2.4, my Dutch language files in the BP-languages folder were gone :’(.

    After all my hard work, I can start again

    @hans, red: You just copy your language into bp-language in buddypress.

    Avatar of red-panda-tech
    Red Panda Tech
    Member

    @red-panda-tech

    I’m really embarrassed to say it but, that did the trick, thanks.

    Avatar of Travel-Junkie
    Boris
    Participant

    @travel-junkie

    When you use the automatic upgrade feature, then all custom files, including all language files in bp-languages, in the BP folders will get deleted. Actually, you could specify a folder outside of BP in which to upload your language files. No more problems when you upgrade…

    load_textdomain( ‘buddypress’, BP_PLUGIN_DIR . ‘/bp-languages/buddypress-’ . BPLANG . ‘.mo’ );

    You want to modify that 2. parameter. Doesn’t really apply to the WPML plugin, though, I guess. Just thought I’d put it out there…

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    @Travel-Junkie, nice hack, worth to be posted on the codex. But where do we put that, bp-custom?

    We’re going to try to locate the language files in a better place for 1.3; I suggest you take a look through http://trac.buddypress.org/; if you can’t find a ticket for this valid suggestion already, make a new one, thanks :)

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.