Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress in a directory breaks nav link in root wordpress install

  • Avatar of copywryter
    copywryter
    Member

    @copywryter

    I looked throughout the forums for a solution to this and tried a number of things, but have given up and added my wail to the wall.

    I added buddypress (1.2.3) as a fresh install (original buddypress theme) in a /community subdirectory of http://www.venture4change.com. (2.9.1 I think) Everything works just fine.

    However, buddypress seems to take over the nav links of the root site. I tried changing the blog address, and also moving off the original bp theme. No luck.

    In addition to suggesting a fix, could you explain to me why this is happening?

    Thanks,

    Copywryter

Viewing 4 replies - 1 through 4 (of 4 total)
  • It adds navigation links to blog ID #1 because… that’s how it works. Are you on WPMU, and /community is a sub-blog?

    If so, you can change which blog BuddyPress runs on by using the following (e.g. blog ID 2) in your wp-config.php:

    define ( 'BP_ROOT_BLOG', 2 );

    http://codex.buddypress.org/how-to-guides/changing-internal-configuration-settings/

    Avatar of copywryter
    copywryter
    Member

    @copywryter

    Hiya, yes /community is a sub-blog, but not of a WPMU installation. Does that matter?

    So on some level two independently installed blogs are controlled by a single wp-config.php file? I guess I don’t understand why they aren’t simply called up as distinct urls.

    I’ll try editing the wp-config.php. Thanks!

    *edit* no I guess I won’t, since I’m guessing that your fix works for MU sub-installations.

    I think you may have a mod-rewrite issue going on. I’m having the same thing happen and that is the direction I’m headed. I’ll let you know the outcome.

    Thanks!

    CPC

    Avatar of copywryter
    copywryter
    Member

    @copywryter

    Any help on this? I’m still struggling.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.