Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress Mobile Switcher Link Broken

  • Avatar of inhouse
    inhouse
    Member

    @inhouse

    Thanks to @modemlooper for the awesome BuddyPress Mobile plugin. I have been using this while a site build was in development and upon launching the site we have just noticed that the switcher link in the footer of the desktop theme is no longer working. We’ve tested this on iPhones, Androids, and Chrome desktop using an agent switcher. BP Mobile recognizes a mobile browser and does use the mobile theme but if you choose to go to the desktop version, you can’t switch back. The link in the footer just reloads the same page in desktop theme. I deactivated WP Super Cache in case that was interfering. I’m not sure what else could be causing this. Is there a way of using domain mapping or have the footer link specifically link to the mobile theme? Something like ‘mydomain.com/mobile’ or something like that? I’m kinda stuck at this point. Thanks for any help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    I’ll check it out, are you using custom theme?

    @modemlooper, it’s a custom BP child theme and the issue is fixed now. I had a guy help me find the issue. I don’t really understand how it was fixed but the important thing is that it’s fixed. I didn’t even know this thread was responded to.

    “A couple of things – first, I found that the trigger was JavaScript driven, so I tracked back the jQuery directions that ran it. I found that they were using jQuery to set a cookie – but there was no jQuery cookie package installed, so I added that. Then, I noted that it *seemed* like that jQuery code was setting a cookie for ‘mobile’ rather than for ‘normal’ when it ran — so it seemed like it was working backwards. I’m not honestly certain which of these changes worked — but as a combination, it worked.”

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    What desktop browser are you using? I couldn’t replicate the switcher not working. I’m not sure about the “cookie package” that’s not a necessity. Glad you got it worked out. Another note, I only test on default BP theme so when you venture into custom themes all plugins could break.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.