Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress/Multisite Installation – Avatar broken images on MU sites and more

  • Avatar of roberte
    roberte
    Participant

    @roberte

    ok. everything is most recent version. re: avatars, everything works great except 1 major issue and 1 minor issue.

    Major Issue: on user blogs all author avatars are broken images. in posts and in comments. the url the image is trying to read from is something like “maindomain.com/files/avatars//-bpthumb.jpg”

    any ideas for a fix for this is much appreciated.

    Minor Issue: on the buddypress side of things all avatars appear as expected, EXCEPT in the activity stream when a user posts a new blog post. when this activity shows up, the avatar used is a buddypress default avatar, not the user’s uploaded avatar. any ideas?

    thanks again all.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of roberte
    roberte
    Participant

    @roberte

    sorry. the sample image link above didn’t display correctly.

    i meant that the image url looks like “maindomain.com/files/avatars//-bpthumb.jpg”

    hopefully this works.

    Avatar of roberte
    roberte
    Participant

    @roberte

    errrr. ok. vars in caps: “maindomain.com/files/avatars/BLOGID/RANDOMCHARACTERS-bpthumb.jpg”

    Avatar of roberte
    roberte
    Participant

    @roberte

    anybody?

    What versions of WordPress and BuddyPress are you using?

    Avatar of teebes
    teebes
    Participant

    @teebes

    There are a few others that have run into this as well, avatars on sub blogs trying to locate avatars under /files/avatars/ instead of /wp-content/uploads/avatars/. Another thread: http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/on-subdomain-blogs-some-avatars-not-displaying/ I noticed this behavior after applying 1.2.6.

    Avatar of roberte
    roberte
    Participant

    @roberte

    Most recent 3.0.1 and 1.2.6. I’ll check the other link out too thanks!

    Avatar of roberte
    roberte
    Participant

    @roberte

    I should also mention here that sub blogs are subdomain configuration and I’m using default theme with bp colors orange child theme. One thing I thought of is that I took out the “members” base using config file method mentioned in buddypress codex. Hosted on hostgator shared with dedicated ip. MU site is main domain on account. Hope this gives someone more relevant info to help.

    Avatar of sapna1809
    sapna1809
    Participant

    @sapna1809

    i am working an websites which is multisite and used one buddypress for 2 domains.
    I got issue in members and groups avatar images.if i set the
    define ( ‘BP_ROOT_BLOG’, blogid ); in wp-config.php then all groups and members avatar images are appear for subdomain but at main domain , all members and groups avatar images are not appear.
    I want to show all groups and members avatar images for both main and subdomain websites for all users which are registered for both websites.

    Please help me…

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.