Skip to:
Content
Pages
Categories
Search
Top
Bottom

Bug: “There was a problem posting your update, please try again.”

  • Avatar of EthanVan
    EthanVan
    Spectator

    @ethanvan

    I’ve just performed a fresh install of WP 3.4.2 and BP 1.6.1 and I am getting the infamous “There was a problem posting your update, please try again.” message. I also patched the bp-activity-classes.php file as instructed starting at line 87. Still getting the error.

    I’m using the default theme. This is extremely frustrating and annoying. What is going on here?

    It seems like nobody knows why this is happening still. have the developers just given up on fixing this bug permanently?

    If anyone else can confirm the same problem please let me know. I need this fixed yesterday. I have other installations running on older version BP 1.5.5 and WP 3.2.1 without error and am scared to death of upgrading due to this error.

    “Here I am, kill me now!”

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    If we could recreate it, of course we’d fix it. Sometimes figuring out why bugs occur is the hardest part.

    Avatar of EthanVan
    EthanVan
    Spectator

    @ethanvan

    Using a GoDaddy Account…

    Install fresh WP 3.4.2 (My mistake an upgrade was performed from 3.3.1!)
    Install and activate BP 1.6.1
    Activate Default BP Theme
    Patch as directed with r6330/r6331

    Try to post.

    Avatar of EthanVan
    EthanVan
    Spectator

    @ethanvan

    I just had success on a different domain. I’m starting to think it’s the WordPress update process is what is causing this bug/error. I thought we had done a 100% fresh WP 3.4.2 install when in fact it was an update.

    So, in order to avoid this bug you MUST install a completely fresh copy of WP 3.4.2 first then BP 1.6.1!

    Performing an update to your old WP will rustle jimmy and cause the BP 1.6.1 install to throw this error.

    Sigh… I hope WP fixes their update process because this is probably the most infamous and common bug known to the BP community. It’s also a pain in the boot.

    Thank you for your response. It was very much appreciated.

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Changeset 6331 was against trunk, not the 1.6 branch. If you are patching 1.6.1 with changeset 6330, then you are running a custom version, and you should let people know how you’ve changed core when asking for support. This could be relevant as this changeset affects activity, which is where you’re having problems.

    Does your site *require* r6330 to work? Are you able to test it running “stock” 1.6.1 work on your upgrade installation?

    Avatar of EthanVan
    EthanVan
    Spectator

    @ethanvan

    Paul, I’m not running with the r6330 patch on 1.6.1, I’m running it stock and it’s fine. The WP update crashed it so I made sure we had a clean fresh install and everything is fine now.

    The only reason I mentioned the patch is because the WP update from 3.3.1 crashed BP posting. I Googled that error and found the patch and tried it but that wasn’t helping. So, be warned that you cannot update WP to 3.4.2 and still be compatible with BP 1.6.1. You must do a fresh install starting from 3.4.2 WP.

    I don’t mess with the core unless I’m trying something on a testing/production basis purely for self satisfaction.

    I’ll be happy to help out with any core updates that you need help with. Testing and debugging is my cup of tea. I have over 7 years experience with modifying WP plugins and have watched it grow from a baby. Also have over 15 years of experience with LAMP and a ton of free time 5 months out of the year.

    I know a lot of developers would like to see changes in the way BP handles messaging. Have you guys considered streamlining and simplifying that functionality?

    I use BP on 7 sites right now. Love it! However, It’s capable of so much more. Let me know how I can help.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.