Skip to:
Content
Pages
Categories
Search
Top
Bottom

Change language

  • Avatar of magnusnordqvist
    magnusnordqvist
    Participant

    @magnusnordqvist

    I run WP 3.6 and BP 1.8.1

    I’ll like everything to be in Swedish. The admin-panel is, but nothing else.
    I’ve read everything I can find here but I can’t find what is wrong. The languages files are in place and the wp-config.php says [define ('WPLANG', 'sv_SE');] as it should.
    I’ve also created a bp-custom.php-file and put a simular code string there. Nothing happens.
    Please help!
    /Magnus

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of danbp
    chouf1
    Participant

    @danbp

    You have nothing to add to bp-custom.php
    If you’re on a local install, verify that the gettext php module is activated.
    If you are on a network install, you have to set your language in WP’s settings
    The translation file path is wp-content/languages/buddypress-sv_SE.mo

    Avatar of magnusnordqvist
    magnusnordqvist
    Participant

    @magnusnordqvist

    Thank you for your answer.
    How do I “verify that the gettext php module is activated”?

    Avatar of magnusnordqvist
    magnusnordqvist
    Participant

    @magnusnordqvist

    Quite desperate here, think I’ve tried everything. It says Swedish everywhere, but still the site is in English. Please help me!!!

    Avatar of danbp
    chouf1
    Participant

    @danbp

    @magnusnordqvist,

    to verify if gettext is enabled localy, you probably have to read your MAMP or WAMP user manual. ;-)

    Did you made your translation correctly ? I mean by usig poEdit (or similar software) to generate the compiled mo file ?

    Once correctly compiled, the translation file must be in the language themes folder.

    wp-content/languages/themes/your_theme-sv_SE.mo
    wp-content/languages/themes/buddypress-sv_SE.mo
    wp-content/languages/themes/twentythirteen-sv_SE.mo

    etc……

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.