Skip to:
Content
Pages
Categories
Search
Top
Bottom

Cropping Avatar

  • Avatar of jpittssr
    jpittssr
    Participant

    @jpittssr

    As much data as I can find:

    wordpress 2.9.2

    Buddypress 1.2

    Hosted on qth.com

    All wp folders set to 777

    new fresh install as of today

    Installed in domain root,

    Also tried installing wordpress in root/wp/

    same problem

    Buddypress default theme

    The thing I find puzzling is, I did an identical on my local box using Xamp and it works perfect.

    My Problem: change avatar; Picture uploads and I can go to the folder and see it. But, after it uploads it does not show up. I inspected the elements with firebug (avatar to crop) and see that there is a / missing in the path to the picture.

    inserting code snippet if it works.

    (<img alt=”Avatar to crop” class=”avatar” id=”avatar-to-crop” src=”wp-content/uploads/avatars/2/Ed_icon2.jpg”>)

    See, there is no / between src=” and wp-contents/uploads

    I don’t know where that line of code comes from but it must be buddypress because it does it regardless of which theme I use.

    I can use firebug to insert the / to test and the image appears

    If you want to look at the site it is bare bones http://carvingsforyou.com

    Hope someone can help. Thanks Ed

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hi Ed,

    I responded to a post you made about 30 mins ago, please check out those threads before creating a new one.

    Avatar of jpittssr
    jpittssr
    Participant

    @jpittssr

    I found the answer posted by Dennis:

    After looking for a solution after a few days I found out, that the upload path handling of WordPress (see “Settings” >> “Miscellaneous”) causes this issue. My fix:

    Clear “Store uploads in this folder”-path

    Set “Full URL path to files” to absolute server path , e.g. “/home/_several_/_folder_/_levels_/wp-content/uploads”

    Ed

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.