Skip to:
Content
Pages
Categories
Search
Top
Bottom

e-mail verification is sending me to home page instead of confirming registration

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of dcavins
    dcavins
    Participant

    @dcavins

    The link should be http://www.myswayspot.com/activate/?key=5fe52bf2f614ef393d2cef3e44765415 by default. Do you have an activate page set up (BuddyPress>Pages)? Are you using permalinks in WP? Which setting? Maybe try disabling permalinks and making a new user…

    & does everything else work on your BP site?

    Avatar of overpoweringsandwich
    overpoweringsandwich
    Member

    @overpoweringsandwich

    I am not using permalinks and everything else works fine on my site. I do not have an activate page set up..how would I go about changing the default activation link and creating a page for it to redirect to? thanks

    Avatar of dcavins
    dcavins
    Participant

    @dcavins

    Go to BuddyPress > Pages in your WordPress Admin menu. You should have a page selected (dropdown menus) for each line. If nothing is selected next to “Activity”, and there’s not a good page to use in the dropdown, use the “New Page” button. All you need to do is name the page and save it; it doesn’t need to have any content. Then, go back to BuddyPress > Pages and select the page you want to use. BP takes care of almost everything, including creating the correct activation link, if you tell it which page to use. :)

    Avatar of tigrrra
    tigrrra
    Member

    @tigrrra

    I was having a similar problem i had the Activate page as a sub page to the Members area.

    Two things you might want to check.

    1. Make sure your Activate page is set to Activate in the BuddyPress > Pages
    2. Go to your Activate page under Pages > All Pages (if you don’t have one create one with no parent) make sure you don’t have it under a different menu as a sub page if you see a – Activate that means you have it as a subpage. it needs to be named Activate and with no parent.

    This worked for me.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.