Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error

  • Avatar of Mark
    Mark
    Participant

    @markhahnel

    ‘Warning: Invalid argument supplied for foreach() in
    /home/collabbo/science3point0.com/wp-content/plugins/bp-my-home/bp-my-home.php
    on line 119′

    Any ideas @imath ?, maybe due to not having friends activated?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of imath
    imath
    Moderator

    @imath

    no it’s because you haven’t saved any bookmark or feed. As when i was testing i had at list one bookmark or feed, i haven’t seen this warning. Thanks for your feedback. I’ll correct this.

    Avatar of imath
    imath
    Moderator

    @imath

    Ok fixed :)
    It will be included on the next upgrade of the plugin (as soon as i end a new widget about comments..) Meanwhile you can edit the `wp-content/plugins/bp-my-home/bp-my-home.php` file this way :

    On line 108 replace the entire function `bpmh_in_array()` with this new one :

    `function bpmh_in_array($search, $list, $type=”activated”){
    $found=0;
    if($type==”activated”){
    $searched_widget = $search.”/”.$search.”.php”;
    if($list!=””){
    foreach($list as $k=>$v){
    if($k==$searched_widget){
    $found=1;
    }
    }
    }
    }
    elseif($type==”user-saved”){
    if($list!=””){
    foreach($list as $bkmk){
    if($bkmk==$search){
    $found=1;
    }
    }
    }
    }
    return $found;
    }`

    Avatar of Mark
    Mark
    Participant

    @markhahnel

    GReat, fantastic responmse time, I’ll get it fixed and let you know.

    Thanks a lot.

    Avatar of Mark
    Mark
    Participant

    @markhahnel

    That appears to have fixed it. Brilliant. Is there a way to make the boxes bigger, my rss feed for example only really shows the latest post as opposed to multiple?

    Avatar of imath
    imath
    Moderator

    @imath

    there’s always a way ;)

    i’m outside for now and can’t view the source code. But you should look into the wp-content/plugins/bp-my-home/widgets folder, then look for the rss widget and inside the display function or css file..
    I’ll be more precise later ;)
    Only the 5 latest entries of the rss feed are shown by default…

    Avatar of Mark
    Mark
    Participant

    @markhahnel

    Thanks a lot.

    Avatar of imath
    imath
    Moderator

    @imath

    Ok here’s how to change the height of the rss reader :
    1. Edit `wp-content/plugins/bp-my-home/widgets/bpmh-rss/bpmh-rss.php` at line 84 :
    `<div id=”rss_container” style=”overflow:hidden;width:100%;height:300px;”>`
    if you change the height parameter to 500px for example, you must have :
    `<div id=”rss_container” style=”overflow:hidden;width:100%;height:500px;”>`

    2. Edit `wp-content/plugins/bp-my-home/widgets/bpmh-rss/js/rss-reader.js` at line 7 with a height of 20px less than you put in step 1, for instance :
    `if(topVal+(maxScroll-480)>=0)`

    Finally to change the number of items displayed by feed, edit `wp-content/plugins/bp-my-home/widgets/bpmh-rss/bpmh-rss.php` at line 43 :
    `$items = $feedBooqy->get_items(0, 5);` replace 5 with the number of your choice.

    that’s it :)

    Avatar of Mark
    Mark
    Participant

    @markhahnel

    Thank you sir, amazing response time.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.