Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum size issues

  • Avatar of norrismp
    norrismp
    Participant

    @norrismp

    For some reason my forums are only taking up half of the available width. I’ve changed everything I can find in the CSS to no avail.

    Here is the forum URL:

    http://snaffuo.com/forums

    Any suggestions?

    My next question is going to be about better meta titles for the forums so if you know that answer too it would be a nice two-fer…

    thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Set forum width = 100% or something. The default theme has:

    table.forum {
    margin: -9px -20px 20px -20px;
    width: auto;
    }

    Have a look in _inc/default.css.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    You actually have no rules set for this table. Tables shrinkwrap to contents width; as Paul says define your table width. tables tend to need defining IE can be a pain with tables if you are not stating properties; also sadly your chosen theme is forcing IE8 into IE7 mode so you have to be aware of how your layout is rendering in a browser that still has issues such as hasLayout constructs.

    Avatar of norrismp
    norrismp
    Participant

    @norrismp

    I changed that to 100% and it still doesn’t change. Here is the Tables/Forum section from default.css:

    /* > Data Tables


    */

    table {

    width: 100%;

    }

    table#message-threads {

    margin: 0 -20px;

    width: 100%;

    }

    table.profile-fields { margin-bottom: 20px; }

    div#sidebar table {

    margin: 0 -16px;

    width: 117%;

    }

    table tr td, table tr th {

    padding: 8px;

    vertical-align: middle;

    }

    table tr td.label {

    border-right: 1px solid #eaeaea;

    font-weight: bold;

    width: 25%;

    }

    table tr td.thread-info p { margin: 0; }

    table tr td.thread-info p.thread-excerpt {

    color: #888;

    font-size: 11px;

    margin-top: 3px;

    }

    div#sidebar table td, table.forum td { text-align: center; }

    table tr.alt {

    background: #f4f4f4;

    }

    table.notification-settings {

    margin-bottom: 20px;

    text-align: left;

    }

    table.notification-settings th.icon, table.notification-settings td:first-child { display: none; }

    table.notification-settings th.title { width: 80%; }

    table.notification-settings .yes, table.notification-settings .no { width: 40px; text-align: center; }

    table.forum {

    margin: -9px -20px 20px -20px;

    width: 100%;

    }

    table.forum tr:first-child {

    background: #fafafa;

    }

    table.forum tr.sticky td {

    background: #FFF9DB;

    border-top: 1px solid #FFE8C4;

    border-bottom: 1px solid #FFE8C4;

    }

    table.forum tr.closed td.td-title {

    padding-left: 35px;

    background-image: url( ../images/closed.png );

    background-position: 15px 50%;

    background-repeat: no-repeat;

    }

    table.forum td p.topic-text {

    color: #888;

    font-size: 11px;

    }

    table.forum tr > td:first-child, table.forum tr > th:first-child {

    padding-left: 15px;

    }

    table.forum tr > td:last-child, table.forum tr > th:last-child {

    padding-right: 15px;

    }

    table.forum tr th#th-title, table.forum tr th#th-poster,

    table.forum tr th#th-group, table.forum td.td-poster,

    table.forum td.td-group, table.forum td.td-title { text-align: left; }

    table.forum td.td-freshness {

    font-size: 11px;

    color: #888;

    }

    table.forum td img.avatar {

    margin-right: 5px;

    }

    table.forum td.td-poster, table.forum td.td-group {

    min-width: 130px;

    }

    table.forum th#th-title {

    width: 100%;

    }

    table.forum th#th-postcount {

    width: 1%;

    }

    Avatar of Anointed
    Anointed
    Participant

    @anointed

    try adding the following to your css

    .forum {

    width:100%;

    }

    Avatar of norrismp
    norrismp
    Participant

    @norrismp

    Nope didn’t change anything…

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Norrismp it likely wouldn’t if you’re editing the rulesets in default.css. Your theme does not appear to be using any styles from the BP default theme all I can see is two primary files ‘styles.css’ that does not conform to the normal stylesheet controlling WP themes and another ‘bp.css’, both thse sheets contain the majority of your styles and it will be there that you need to place the rulesets for your table styling.

    Avatar of norrismp
    norrismp
    Participant

    @norrismp

    in my main theme’s CSS tables are defined as having 99% width, which these obviously don’t.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    @norrismp

    Just add what everyone has suggested and that is:

    table.forum {width:100% !important;}

    Somewhere at the end of your Atahualpa theme’s stylesheet:

    Avatar of norrismp
    norrismp
    Participant

    @norrismp

    Thanks Ray! I was adding it to default.css but adding it to the Atahualpa CSS worked like a charm!

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    :-) thought that was what I had pointed out , but hey ho

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.