Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forums disappear (end up as 404 Not Found) every 12 hours or so

  • We have several instances of a BuddyPress site (LIVE, DEV & LOCAL). The DEV & LOCAL sites are exact duplicates of the LIVE site from about a week ago. (We occasionally sync the LIVE site to our DEV & LOCAL sites to make development & testing easier.)

    Currently, LIVE is running WordPress v3.3.2 and BuddyPress v1.5.6. We performed auto-updates on DEV & LOCAL after the sync we performed last week; so DEV & LOCAL are running WordPress 3.4.1 while LIVE is still running 3.3.2.

    Anyway, we’re having trouble with our DEV site “forgetting” that the forums component is installed/activated. Every 12 hours or so, visiting the forums section of the DEV site (any group’s ~/forum/* address) returns a WordPress 404, Page Not Found. To reactivate the forums, all we have to do is login to WP Admin, and visit the BuddyPress -> Forums settings page. Just viewing the forum settings page fixes whatever issue is causing the 404; no re-saving or updating of the settings is necessary.

    I’ve verified that the following rewrite settings are correct and the same between the three sites:
    `$wp_rewrite->wp_rewrite_rules()`
    `$wp_rewrite->permalink_structure`
    `$wp_rewrite->get_page_permastruct()`
    `$wp->matched_rule`
    `$wp->request`

    But, when we get to the actual query (`$wp_the_query`) the `query_vars` are correctly asking for a `pagename` of `forum`, but the query var `is_page` is FALSE, `is_404` is TRUE and there is no `queried_object` returned.

    I’m stumped. I’m sure that somewhere there is a filter or option that is getting dropped somehow, but I have no idea where it might be. This issues does not affect LIVE or LOCAL, only DEV so we’ve ruled out a difference in the version of WordPress.

    Any ideas, or even a bit of a walk through for how the forums are activated would be much appreciated.

    Thanks!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.