Skip to:
Content
Pages
Categories
Search
Top
Bottom

"Friendly HTTP Error Messages" causes 404

  • Avatar of Cce
    cce
    Participant

    @cce

    I’ve set up Buddypress 1.2.1 on WordPress MU 2.9.2. It is running on IIS6 with Mod_Rewrite Pro from Micronovae. PHP is 5.2.13 FastCGI 1.5 (also tested ISAPI version). WPMU has been running for more than a year.

    I’m getting 404 errors in certain places with IE. The easiest way to replicate the problem is by clicking the “Create a Group” button. That links to http://fqdn/groups/create, which is supposed to redirect to http://fqdn/groups/create/step/group-details. However, if IE’s “Show Friendly HTTP Error Messages” is turned on (which is the default), a 404 error message is displayed. If you turn it off, it works correctly. If you go straight to the /groups/create/step/group-details URL it also works. It also happens with Firefox if you have the Google Toolbar installed, which also intercepts error messages.

    Based on some Googling, there are other people with unexplained 404 errors, many running on IIS, and this might be the cause of their problems as well. I don’t know if this is specific to IIS, or if there is some other combination of settings that are causing it. I’ve talked to Micronovae and they say it isn’t related to URL rewriting.

    Does anyone have any ideas? Obviously, telling everyone to turn off “Friendly HTTP Error Messages” or disabling toolbars is not a good option.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.