Skip to:
Content
Pages
Categories
Search
Top
Bottom

Group, Forums, Blogs and Register pages are not working.

  • Avatar of davidniyat
    davidniyat
    Participant

    @davidniyat

    Hi,
    I’ve installed Buddypress on my Linux based, standard apache 2 LAMP servers, with PHP 5.2.12-14, and MySQL at latest stable.

    First up site was running on the wordpress, but later with the help of two plguins BuddyPress and BuddyPress Template Pack, I’ve installed buddypress and made my theme buddypress compatible as well.

    Now, Activity, Member pages are working perfectly but, Gropus, Forums, Blog and Registration pages are either giving “page not found” error or, redirecting page to homepage of the site.

    Also,at some instance it gives, call to undefined function bp_dtheme_page_on_front(); error when I tried to add navigation of bp-default theme into my theme.

    Here is the URLs of my site http://www.funkybingo.co.uk/, http://www.funkybingo.co.uk/activity, http://www.funkybingo.co.uk/members, http://www.funkybingo.co.uk/forums, http://www.funkybingo.co.uk/groups

    I would appreciate any help over this issue.

    Thanks
    David

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @davidniyat – you can’t just cut and paste sections from the default theme if they rely on functions that are defined elsewhere in the theme. It’s designed to be use a parent theme.

    The bp_dtheme functionality is embedded / used in various places in the theme. In particular, you need to take a look at the functions.php file where those functions are defined.

    Avatar of davidniyat
    davidniyat
    Participant

    @davidniyat

    thanks @Roger Coathup , ur remakrs helped me to solve that navigation error.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.