Skip to:
Content
Pages
Categories
Search
Top
Bottom

Group forums not working? On a DV?

  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I haven’t been able to get group forums up and running. Until now that is.

    If you have problems getting this up and running and you are on a Dedicated Virtual Server (DV) then you may need to edit the /etc/hosts file on your box. bp uses a goodie from sambauers that uses xmlrpc to talk to bbpress.

    The little goodie relies on a php lib called curl. curl goes out and gets some stuff from bbpress to find an xmlrpc connection endpoint to talk to. Well, curl relies on the operating system to tell it the ip address of the url we need to talk to. I want to connect to ‘ourcommoninterest.org/bbpress/’ in my case.

    To resove the host ‘ourcommoninterest.org’ into an ip address it first looks in my local /etc/hosts file. If it can’t find what it’s looking for then it goes out and uses dns to resolve the host name.

    Since I’m running on a dv my hosts file just contains a standard entry for my domain with an alias for ‘localhost’. It read:

    /etc/hosts

    127.0.0.1 ourcommoninterest.org localhost localhost.localdomain

    Evidently apache pays some attention to this hosts file but not much since it’s been resolving my domain name to the proper ip address all along and it’s only 127.0.0.1 to utils that run on the box.

    mu is a util that runs on the box if it is using the curl lib to GET results from an url. So sam’s goodie, mu and bp were being told by the curl lib that my domain didn’t exist. That the url I have bbpres setup at was 404. The curl, thru the hosts file thought my ip address was 127.0.0.1

    I went to tech support at my host and explained that I was using curl and getting 404s for valid urls on my domain. They explained that ‘well yah ya dummy’ the hosts file contains such and such and is returning so and so.

    I changed my hosts file to the following and everything is happy now.

    /etc/hosts

    127.0.0.1 localhost localhost.localdomain

    99.99.99.999 ourcommoninterest.org ourcommoninterest

    The 99′s are obviously not my actual ip address. curl goes out and finds my domain and my ip address and purrs merrily along.

    Don’t forget to keep the localhost line in there. Just add your ip/hostname to the list.

    If you want to know *way* more than you care to about the linux hosts file just google ‘linux hosts file’.

    Welcome to linux sysadmin 101. This is your first lesson Burt. Pay attention now.

    (can I go back to hacking my theme up again?)

Viewing 7 replies - 26 through 32 (of 32 total)
  • Avatar of Chad Holden
    Chad Holden
    Participant

    @holdench

    I am supposed to NOT CHECK >>

    Add cookie integration settings

    If you want to allow shared logins with an existing WordPress installation.

    >> right?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    All yours John. :)

    Avatar of Chad Holden
    Chad Holden
    Participant

    @holdench

    Nothing huh? God this is frustrating.

    Avatar of Chad Holden
    Chad Holden
    Participant

    @holdench

    It’s getting wierder! I just installed all of this on my local MAMP server and all works as it should. The install was quite easy to complete overall. The client uses a windows server with apache, mysql 5 and php 5. Could this really be the problem?

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    holdench, some of the variables between operating systems that could be hosed in the Windows version are:

    Check that the bp user you have in bbPress Forums config on the bp side has ‘administrator’ rights.

    Check that you have user switching turned on in bb-config.php with this:

    $bb->bb_xmlrpc_allow_user_switching = true;

    Lots of little things can be off. If any ONE isn’t right, things get weird or just don’t work period.

    Avatar of Chad Holden
    Chad Holden
    Participant

    @holdench

    http://webomania.wordpress.com/2006/10/01/out-of-range-value-adjusted-for-column-error/ <- this is actually the solution right here. I dont know how it works, but it fixed my problem completely.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Sorry to have abandoned this one, I’ve been sick the past two days and somehow missed coming back to it. :(

    I will however mark this one as resolved! Not that I deserve the honors ha!

Viewing 7 replies - 26 through 32 (of 32 total)

You must be logged in to reply to this topic.