Skip to:
Content
Pages
Categories
Search
Top
Bottom

Having some trouble with Avatar uploads and forum posts

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    Roxanne,

    What versions of BuddyPress and WP-Mu are you using? What other plugins are you using? What is the directory structure? Have you checked permissions of the directories?

    Avatar of Roxanne
    Roxanne
    Participant

    @onlinewoman

    Thanks LPH.

    We’re running WordPress MU version 2.9.2
    Buddypress version 1.2.4.1

    Active plugins include:
    BP Contents Version 1.0
    BP Group Calendar Version 1.2.1
    Welcome Pack Version 2.0.3
    Akismet Version 2.2.9
    All in One SEO Pack Version 1.6.11
    BuddyPress Album+ Version 0.1.7
    Contact Form 7 Version 2.2.1
    Embedded Video Version 4.1
    PollDaddy Polls Version 1.8.7
    Really Simple CAPTCHA Version 1.1
    Remove BuddyPress AdminBar Version 1.2
    Seo for Buddypress Version 1.2.4
    WordPress Hashcash Version 4.5.1
    WPaudio Version 2.2.0

    And yes I’ve checked and rechecked permissions and that all appears to be fine. Just not sure what I could check next? Thanks for your help!

    Avatar of Roxanne
    Roxanne
    Participant

    @onlinewoman

    This has really become a serious issue on our site. Anyone else have some suggestions for me?

    Avatar of Roxanne
    Roxanne
    Participant

    @onlinewoman

    Okay, after literally hours of phone calls, trial-and-error, google searches and bugging the tech guys at my hosting company I finally found the fix. I’ll outline here in case anyone has this same issue in the future.

    First of all this is a HUGE wordpress-mu issue. There are tons of folks out there with the same problem, which is apparently related to folks on dedicated servers.

    The problem I finally realized was my FTP client couldn’t actually change the read/write on blogs.dir
    I kept doing a chmod but didn’t see that it never took. Once I realized the problem I found out that somehow wordpress-mu creates new files/folders dynamically using apache:apache as the owner:group. So the server then denied the creation because it wasn’t the right “owner” for those permissions.

    Here was my fix (hopefully I haven’t mucked up my security too much doing this).

    1) I turned off safe mode in Plesk. I’m hoping since I’m the only one in there, this won’t be too big of an issue.
    2) I used an SSH login session to go to my wp-content directory
    3) I did a chown OWNERNAME:GROUPNAME blogs.dir -R command
    4) went back to my FTP session and did a chmod on the blogs.dir folder recursively

    Now it appears to work (*fingers crossed*)

    Avatar of Roxanne
    Roxanne
    Participant

    @onlinewoman

    Well I was hoping this would work, but apparently it hasn’t fixed the issue. New users are not able to upload their profile photos as the system is creating new folders with the incorrect permissions. Is there any way around this without having to try and blow up my server by attempting an suPHP module?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.