Skip to:
Content
Pages
Categories
Search
Top
Bottom

Home Page Forced To Activity Page

  • Avatar of Brad
    Brad
    Participant

    @cmubrad

    I updated my site to WP 3.0 and BP 1.25 and everything went fine. I wanted to see what my site would look like with the activity stream as the home page so I set it as the home page in my wp admin area. After deciding that I did not want to have it as my home page I tried to set it back to most recent posts. Unfortunately, it would not switch back. The home page now forwards to my activity stream regardless of the settings in my admin area. I found another thread with a functions.php patch but this did not work and either did putting the 1.2.4.1 functions.php file.

    Does anybody know a fix to get things back to normal? My site is http://workoutjourney.com. Notice how it forwards to the activity stream when clicking on the home page link.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Revert all functions.php mods you made.

    Login to the WP backend, navigate to “Settings > Reading”.

    Make sure under “Front page displays” that “Your Latest Posts” is selected.
    http://codex.wordpress.org/Settings_Reading_SubPanel

    Save and check your frontpage.

    Avatar of Brad
    Brad
    Participant

    @cmubrad

    See that’s the weird thing. I did not do any mods. I checked it out with activity as home page, did not want it, and then tried to change it back exaclty as you stated above and it still forwards to the activity stream. I then went looking for info and found the different functions.php files but they are the same as the one I initially had with the BP 1.25 update.

    Its like the site is stuck there and I can’t get it to go back.

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    I just tried to duplicate your problem on my local install, but couldn’t.
    Perhaps something else is interfering and causing the redirect?

    Are you using any BP plugins that handle redirection?
    Anything in your .htaccess file? Any custom code in your theme’s functions.php?

    If that fails, you can always set another WP page as the default front page. Then see if the redirect still occurs.

    Avatar of Brad
    Brad
    Participant

    @cmubrad

    @ r-a-y

    Got it fixed. I have the redirection plugin from Urban Giraffe on my site. Its given me issues in the past. When I de-activated it the site went back to my home page. Thanks for the tip.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.