Skip to:
Content
Pages
Categories
Search
Top
Bottom

Is this a bug? Activity deletion and “Are you sure” dialog box

  • Avatar of tifire
    tifire
    Participant

    @tifire

    This problem has been bugging me for a long time. When deleting an activity update by clicking the “delete” button below it, sometimes I see the “Are you sure” dialog box for me to confirm the deleting, but at other times the activity update is deleted without the “Are you sure” dialog box.

    I have tested this on testbp.org and my own test site. Here is what I found:
    1) Right after posting an activity update, no “Are you sure” dialog box shows up if I click the “delete” button. The activity update is just deleted.
    2) After posting an activity update, if I refresh the page then click the “delete” button, the “Are you sure” dialog box shows up for me to confirm the deletion.
    3) If I refresh the page, select any of the filter ( everything, updates, new groups, group memberships, etc), then all my activity updates can be just deleted without seeing the “Are you sure” dialog box.

    It should be required for users to confirm the deletion all the time. Otherwise they would be confused and frustrated if deleting something by accidence. What can I do to have the “Are you sure” dialog box all the time?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    No need to crosspost on both here and on http://buddypress.trac.wordpress.org/ticket/4458 — we read both.

    I would say generally that whatever the behaviour should be, it ought to be consistent.

    Avatar of tifire
    tifire
    Participant

    @tifire

    Just thought it might be a bug, so I also submited the ticket there. Sorry about that.

    >>> “I would say generally that whatever the behaviour should be, it ought to be consistent.”

    If deletion doesn’t require user confirmation all the time, it is not consistent. Right?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.