Skip to:
Content
Pages
Categories
Search
Top
Bottom

Major Problem with the Extended Profiles and adding another Extended Profile Group w/Deletion

  • Avatar of BlinkyBill01
    BlinkyBill01
    Participant

    @blinkybill01

    I made a second Extended Profile Group tab and moved items from my default “Base” tab to it. Well, I accidentally deleted the second Group tab and instead of moving the Profile Fields back to the “Base” tab, it deleted the groups as well as the new tab.

    The major problem: the profile field listed “Name (Primary) (Required)” was in that new tab.

    So now I’m without that field and it’s an essential part of the site.

    Is there a way to re-add the “Name (Primary) (Required)” to my BuddyPress Extended Profiles? The other fields that were deleted are easy enough to recreate, just that I’m not sure how this would work with the Name field.

    For future updates to BuddyPress, can you include either and “undo” or make all fields in other fields fall back to the Base group?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of BlinkyBill01
    BlinkyBill01
    Participant

    @blinkybill01

    Well, crisis averted, I think.

    I deactivated Extended Profiles then reactivated it and the Name (Primary) (Required) reappeared. Just need to check and see if it did any damage to users that edited their profile while the Name feature wasn’t enabled.

    Ouch. I’m glad re-enabling the component got it back again.

    Adding “trash” to all the things in BuddyPress is something we want to do in future versions, yes.

    Avatar of BlinkyBill01
    BlinkyBill01
    Participant

    @blinkybill01

    Ok, I guess the deactivate/reactivate sort of worked in that it readded the Name field back to the page. The only issue now is that it’s not “aligned” correctly to BuddyPress.

    In Profile > Edit when changing your name, it changes the name but not the “nicename”. So a user I have is named Mike with the nicename @alfred.

    Dunno what to do about this.

    Avatar of BlinkyBill01
    BlinkyBill01
    Participant

    @blinkybill01

    @DJPaul, I’m still having this problem described in my previous post. While the Name (Primary) (Required) returned after I re-enabled Extended Profiles, it’s not correctly linked to the actual WordPress naming system.

    If a user registers with the username “william” and they put “Bill” as the Name (Primary) (Required) their username and nicename both show as “william.” Then if the user goes into the settings to change their name to, say Toby, they get this on the BuddyPress profile page:

    Toby
    @william

    If I’m not mistaken, the Name and Nicename should automatically be changed to display the same name, just with the @ before the nicename?

    Is there any way to re-add the original files without reinstalling BuddyPress so that it correctly links up?

    Avatar of BlinkyBill01
    BlinkyBill01
    Participant

    @blinkybill01

    Anyone? This is kind of a big issue, not just with my site but anyone that has extended profiles activated. If you can delete a Primary/Required field, that’s big in itself. But if it can be automatically re-added by disabling/enabling XProfiles, and it doesn’t sync up when it’s re-enabled, then most people will not know there is an issue till it’s too late.

    Since I disabled Extended Profiles then Re-enabled it, numerous times, I now have 8 (eight) Name (Primary)(Required) fields in the extended profiles area that do not sync up nor can they be deleted.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.