Skip to:
Content
Pages
Categories
Search
Top
Bottom

No blogs shown in Admin Bar’s My Blogs unless Re-Activating BuddyPress.

  • Avatar of chestnut_jp
    chestnut_jp
    Member

    @chestnut_jp

    I know that the same kind of problem was discussed before, and people said the bug was fixed.

    I am using BP 1.2.6 with WP 3.0.3.
    When a user registered to a site, the user belongs to the site blog.

    However, the user’s “My Blogs” in admin bar has no blogs.
    Upon re-activating the buddypress plugin (first deactivate it and then activate it), the site blog is listed in the user’s My Blogs.

    I think something like hooks reading blogs users are belonging to does not work in the buddypress.

    Are there any one facing the same trouble or having any solutions? I really need help against this.

Viewing 11 replies - 1 through 11 (of 11 total)
Avatar of Andrea Rennick
Andrea Rennick
Participant

@andrea_r

The “My Blogs” list will only show the blog that user has *admin access* on. Not any other blog they happen to be a member of.

Avatar of chestnut_jp
chestnut_jp
Member

@chestnut_jp

Thanks for your reply, @andrea_r

If so, why re-activating buddypress plugin makes a blog that the user belongs to show up in his/her “My Blogs” and listed in his/her “Blog Directory”?
I do not remember when, but the old (previous) buddypress immediately showed the site blog in “My Blogs” of the user who is a member of that blog.

It is weird that the user can post in the blog that is not shown in “My Blogs” nor not listed in “Blog Directory”, isn’t it?

Avatar of Andrea Rennick
Andrea Rennick
Participant

@andrea_r

No, becasue that’s how core multisite works.

Avatar of chestnut_jp
chestnut_jp
Member

@chestnut_jp

Hi @andrea_r,

Do you mean it is natural that the buddypress plugins is re-activated in order to show site blog under each user’s My Blogs?
Sorry, but I am not with you…

How about your buddypress site? Each user does not have site blog under their My Blogs unless the re-activation of buddypress plugin?

If so, I will report it as a bug to the tracker, since it does not hapen only for me, and I really do want this to be fixed.
Anyway, aren’t there any other people seeing the same thing happening?

Avatar of Andrea Rennick
Andrea Rennick
Participant

@andrea_r

no, I was referring to the fact that core wordpress only shows a user’s blog under “My sites” that they are admin on.

If you alreayd have users with blog, and then add buddypress, then yes – this has been a persistant issues. BP doesn’t automagically go find them all.

Avatar of chestnut_jp
chestnut_jp
Member

@chestnut_jp

Hi @andrea_r,
Oh, I see.

But my situation is a little bit defrrent from what you seem to understand.
First, I use WP 3.0.3 with multi site enabled. Then I install buddypress plugin and enable it.
Thus, I have no extra blog but only one attached to buddypress (primary) site.

In this situation, a user registers the site and he/she becomes “author” of the site blog. However, it does not show in the user’s “My Blogs” nor listed in “Blog Directory”.

As a result, when the user wants to post, he/she has to access to dashboard by typing directory the url of dashboard.
Of course, the user can post a new post, and it will be displayed in the site blog. Nevertheless, the user still can not see the site blog in his/her “My Blogs” in the admin bar nor in “Blog Directory” until the administrator re-activates the buddypress plugin.

I do not think this is due to WP core features. I think this is a bug lies in the buddypress plugin.

How do you think?

Avatar of chestnut_jp
chestnut_jp
Member

@chestnut_jp

Avatar of chestnut_jp
chestnut_jp
Member

@chestnut_jp

I changed the version from 1.2.6 to 1.3, as it is still awaiting review.

Avatar of smiranda
smiranda
Member

@smiranda

I am having the same issue. But only during recent development did that ‘my blogs’ link disappear. So I will now be retracing my dozens of hours of changes to try to figure out what i might have done that triggered the erroneous state.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.