Skip to:
Content
Pages
Categories
Search
Top
Bottom

no tables created when BP installed

  • Avatar of Mgrunk1
    mgrunk1
    Participant

    @mgrunk1

    I have a new WP MU install – everything looked fine. I installed the BP plug from dashboard. It gets all the files and I can activate the plug in and access the component, but there are error messages stating that no wp_bp tables exist – I confirmed via phpmyadmin that no wp_bp tables exist. I saw a thread back in January but I’m not an 1 & 1 and there were was no solution posted. At this point do I need to manually create the tables? Is there a sql script available to run?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    What version bp, wpmu and what are the exact error messages you get.

    Avatar of Mgrunk1
    mgrunk1
    Participant

    @mgrunk1

    BuddyPress 1.0

    Wordpress MU 2.7.1

    *replaced db name w/ mydb – and this is the errors that show at the bottom of the page in the admin – if I delete the BP plugin, the messages all go away.

    WordPress database error Table ‘mydb.wp_bp_xprofile_data’ doesn’t exist for query SELECT d.value, f.name FROM wp_bp_xprofile_data d, wp_bp_xprofile_fields f WHERE d.field_id = f.id AND d.user_id = 1 AND f.parent_id = 0 AND f.name = ‘Name’ made by require, require_once, require_once, require_once, do_action, call_user_func_array, bp_core_setup_globals, bp_core_global_user_fullname, bp_fetch_user_fullname, xprofile_get_field_data, BP_XProfile_ProfileData->get_value_byfieldname WordPress database error Table ‘mydb.wp_bp_xprofile_fields’ doesn’t exist for query SELECT id FROM wp_bp_xprofile_fields WHERE name = ‘Name’ made by require, require_once, require_once, require_once, do_action, call_user_func_array, bp_core_setup_globals, bp_core_global_user_fullname, bp_fetch_user_fullname, xprofile_set_field_data, xprofile_get_field_id_from_name, BP_XProfile_Field->get_id_from_name WordPress database error Table ‘mydb.wp_bp_notifications’ doesn’t exist for query SELECT * FROM wp_bp_notifications WHERE user_id = 1 AND is_new = 1 made by require, require_once, include, get_footer, locate_template, load_template, require_once, wp_footer, do_action, call_user_func_array, bp_core_admin_bar, do_action, call_user_func_array, bp_adminbar_notifications_menu, bp_core_get_notifications_for_user, BP_Core_Notification->get_all_for_user

    Avatar of Mgrunk1
    mgrunk1
    Participant

    @mgrunk1

    http://buddypress.org/forums/topic.php?id=1096

    This post after some digging has all the sql code to define all the tables – it worked and now I can proceed. Still have no idea why there’s a problem – I had to put code in the wp-config because it infinited looped upon admin login. I was not able to select subdirectories as an install option – only subdomains. And, then the buddypress table issue. I assume it’s some kind of funked, esoteric issues w/ my hosting company (shared) but I haven’t had a problem w/ any zen-cart, zoomla or wp installs.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    OK. That’s good that you are up and running. Some hosts just have difficulty with bp. It doesn’t happen very often, perhaps 3 or 4 users have reported such things. Mostly with one particular host.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.