Skip to:
Content
Pages
Categories
Search
Top
Bottom

oembed in BP 1.5 activity stream – is this a bug?

  • Avatar of rossagrant
    rossagrant
    Participant

    @rossagrant

    Hi all,

    Loving having oembed in my activity stream in 1.5, but I’ve noticed that in order to have a link actually embed, it MUST sit on it’s own line, with no other text on the line.

    eg. if I was making a status update like this:

    Hi guys watch this: http://youtu.be/e72S1VrDeDY

    IT WON’T EMBED

    Instead I need to make my update like this:

    Hi guys watch this:

    http://youtu.be/e72S1VrDeDY

    Even sitting on the line directly under the status update means it won’t embed.

    It actually has to be on a line with nothing above or below it.

    Obviously our members are going to link to stuff mid sentence I expect.

    Any way we can rectify this?

    Thanks! :)

Viewing 2 replies - 1 through 2 (of 2 total)
  • Not a bug. It matches exactly how they work in WordPress posts. I think we’d need a good argument to change the behaviour.

    Avatar of rossagrant
    rossagrant
    Participant

    @rossagrant

    Hey Paul, thanks for that.

    Just seems members will normally place links in the midst of text, thus not everything is going to get embedded.

    You can place a link anywhere in text on Facebook etc and it detects it.

    It’s no great problem, but it;s cooler to show embedded stuf, rather than links.

    You can see the behaviour in my post above.

    One embeds, one doesn’t, yet the difference is tiny in how it is written.

    Do you think it’s worth me posting it to the WordPress guys?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.