Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Plugin: Blog Topics For WPMU] With BuddyPress doesn’t work properly

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    @romik84 – I saw your post on here:
    http://wordpress.org/support/topic/415399

    I haven’t looked too far into this, but there doesn’t appear to be a “wpmu_new_blog” filter:
    add_filter('wpmu_new_blog', array(&$cets_wpmubt, 'set_new_blog_topic'), 101);

    However, there is an action called “wpmu_new_blog”, maybe that is what the plugin author meant?
    add_action('wpmu_new_blog', array(&$cets_wpmubt, 'set_new_blog_topic'), 101);

    Avatar of Romik84
    Romik84
    Member

    @romik84

    my current code looks like this:

    `// Add the actions and filters we need to make all this run
    add_action(‘signup_blogform’, array(&$cets_wpmubt, ‘get_topics_select_signup’));
    add_filter(‘wpmu_new_blog’, array(&$cets_wpmubt, ‘set_new_blog_topic’), 101);
    add_filter(‘wpmu_activate_blog’, array(&$cets_wpmubt, ‘set_new_blog_topic’), 101);
    add_action(‘bp_after_blog_details_fields’, array(&$cets_wpmubt, ‘get_topics_select_signup’));
    add_action(‘signup_finished’, array(&$cets_wpmubt, ‘save_signup_blog_topic’));
    add_action(‘bp_signup_usermeta’, array(&$cets_wpmubt, ‘save_signup_blog_topic’));
    add_action(‘admin_menu’, array(&$cets_wpmubt, ‘add_submenu’));
    add_action(‘admin_menu’, array(&$cets_wpmubt, ‘add_siteadmin_page’));
    add_action(‘delete_blog’, array(&$cets_wpmubt, ‘update_relationships’));`

    this add the select menu in the Sign Up form but it still doesn’t save the selected Topic for the blog. Any ideas?

    Avatar of Romik84
    Romik84
    Member

    @romik84

    hey guys, no idea?

    Has she not updated this in the mean time? I’m using the latest version on a BP install and it all works great (I’ve changed it’s presentation a lot).

    @clivoo I am using now WP MU 3.0.1 and Blog Topic 1.0, but it’s not working for new Sign Ups. If you are logged in and create a blog, it works. How you got it working?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.